Bug 858740 - SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file /usr/bin/wodim.
SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file /usr...
Status: CLOSED DUPLICATE of bug 858738
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8809d57beadb4496573199c805c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 10:40 EDT by Raman Gupta
Modified: 2012-09-19 20:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 20:00:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raman Gupta 2012-09-19 10:40:09 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.9-2.fc16.x86_64
time:           Wed 19 Sep 2012 10:39:56 AM EDT

description:
:SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file /usr/bin/wodim.
:
:*****  Plugin samba_share (98.5 confidence) suggests  ************************
:
:If you want to allow smbd to have getattr access on the wodim file
:Then you need to change the label on '/usr/bin/wodim'
:Do
:# semanage fcontext -a -t samba_share_t '/usr/bin/wodim'
:# restorecon  -v '/usr/bin/wodim'
:
:*****  Plugin catchall (2.42 confidence) suggests  ***************************
:
:If you believe that smbd should be allowed getattr access on the wodim file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep smbd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:smbd_t:s0
:Target Context                system_u:object_r:cdrecord_exec_t:s0
:Target Objects                /usr/bin/wodim [ file ]
:Source                        smbd
:Source Path                   /usr/sbin/smbd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           samba-3.6.6-88.fc16.x86_64
:Target RPM Packages           wodim-1.1.11-12.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-91.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.9-2.fc16.x86_64 #1 SMP Thu Aug 23
:                              17:51:29 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 19 Sep 2012 10:36:10 AM EDT
:Last Seen                     Wed 19 Sep 2012 10:36:10 AM EDT
:Local ID                      51efc6f9-277f-4cf2-a1cd-13522e5adeef
:
:Raw Audit Messages
:type=AVC msg=audit(1348065370.649:5608): avc:  denied  { getattr } for  pid=17328 comm="smbd" path="/usr/bin/wodim" dev="dm-0" ino=44715 scontext=system_u:system_r:smbd_t:s0 tcontext=system_u:object_r:cdrecord_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1348065370.649:5608): arch=x86_64 syscall=stat success=no exit=EACCES a0=7f03a579b880 a1=7fff94aa9420 a2=7fff94aa9420 a3=73 items=0 ppid=1625 pid=17328 auid=4294967295 uid=0 gid=0 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=4294967295 comm=smbd exe=/usr/sbin/smbd subj=system_u:system_r:smbd_t:s0 key=(null)
:
:Hash: smbd,smbd_t,cdrecord_exec_t,file,getattr
:
:audit2allow
:
:#============= smbd_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     samba_export_all_ro, samba_export_all_rw
:
:allow smbd_t cdrecord_exec_t:file getattr;
:
:audit2allow -R
:
:#============= smbd_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     samba_export_all_ro, samba_export_all_rw
:
:allow smbd_t cdrecord_exec_t:file getattr;
:
Comment 1 Daniel Walsh 2012-09-19 20:00:30 EDT

*** This bug has been marked as a duplicate of bug 858738 ***

Note You need to log in before you can comment on or make changes to this bug.