Bug 858741 - if Xorg dies then graphical login fails forever (even upon reboot)
if Xorg dies then graphical login fails forever (even upon reboot)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 10:42 EDT by John Reiser
Modified: 2012-09-19 20:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 20:03:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2012-09-19 10:42:16 EDT
Description of problem: After /usr/bin/Xorg server terminates unexpectedly, then all subsequent attempts at graphical login fail, even after reboot.


Version-Release number of selected component (if applicable):
gnome-desktop3-3.5.91-1.fc18.x86_64

How reproducible: every time


Steps to Reproduce:
1. # kill -TERM <pid-of-/usr/bin/Xorg>   ## terminate X11 server
2.
3.
  
Actual results: Graphical screen restarts and displays the blue-streak-and-stars background image, but then "Oh no! Something has gone wrong.  A problem has occurred and the system can't recover.  Please log out and try again.  [LogOut]".  Clicking the [LogOut] button just repeats the cycle.  The badness persists even after reboot.


Expected results: Fresh screen for graphical login to new session.


Additional info:  I got into this predicament because there is no option to logout.  Also, Ctrl-Alt-Backspace does not restart the Xserver like it used to.  So I Ctrl-Alt-F2 to get a VGA terminal, login as root, and terminate /usr/bin/Xorg.  Now I cannot login, not even after reboot.
Comment 1 John Reiser 2012-09-19 20:03:13 EDT
Fixed by "yum update" which included:
Sep 19 16:55:15 Updated: glib2-2.33.12-1.fc18.x86_64
Sep 19 16:55:16 Updated: gobject-introspection-1.33.10-1.fc18.x86_64
Sep 19 16:55:16 Updated: telepathy-glib-0.19.9-1.fc18.x86_64
Sep 19 16:55:17 Updated: 1:control-center-filesystem-3.5.91-1.fc18.x86_64
Sep 19 16:55:18 Installed: harfbuzz-0.9.4-1.fc18.x86_64
Sep 19 16:55:19 Updated: pango-1.31.1-1.fc18.x86_64
Sep 19 16:55:21 Updated: gvfs-1.13.8-1.fc18.x86_64
Sep 19 16:55:28 Updated: webkitgtk3-1.9.91-1.fc18.x86_64
Sep 19 16:55:30 Updated: evolution-data-server-3.5.91-1.fc18.x86_64
Sep 19 16:55:35 Updated: evolution-3.5.91-1.fc18.x86_64
Sep 19 16:55:35 Updated: nautilus-extensions-3.5.91-1.fc18.x86_64
Sep 19 16:55:38 Updated: nautilus-3.5.91-1.fc18.x86_64
Sep 19 16:55:40 Updated: gnome-keyring-3.5.91-1.fc18.x86_64
Sep 19 16:55:42 Updated: gnome-settings-daemon-3.5.91-1.fc18.x86_64
Sep 19 16:55:43 Updated: anaconda-widgets-18.6.8-1.fc18.x86_64
Sep 19 16:55:44 Updated: mutter-3.5.91-2.fc18.x86_64
Sep 19 16:55:45 Updated: chrony-1.27-0.5.pre1.git1ca844.fc18.x86_64
Sep 19 16:55:48 Updated: anaconda-18.6.8-1.fc18.x86_64
Sep 19 16:55:49 Updated: gnome-shell-3.5.91-1.fc18.x86_64
Sep 19 16:55:54 Updated: 1:control-center-3.5.91-1.fc18.x86_64
Sep 19 16:55:55 Updated: gnome-keyring-pam-3.5.91-1.fc18.x86_64
Sep 19 16:56:07 Updated: evolution-help-3.5.91-1.fc18.noarch
Sep 19 16:56:12 Updated: empathy-3.5.91-1.fc18.x86_64
Sep 19 16:56:12 Updated: gvfs-archive-1.13.8-1.fc18.x86_64
Sep 19 16:56:13 Updated: gvfs-afc-1.13.8-1.fc18.x86_64
Sep 19 16:56:13 Updated: gvfs-obexftp-1.13.8-1.fc18.x86_64
Sep 19 16:56:14 Updated: gvfs-gphoto2-1.13.8-1.fc18.x86_64
Sep 19 16:56:14 Updated: gvfs-smb-1.13.8-1.fc18.x86_64
Sep 19 16:56:15 Updated: gvfs-fuse-1.13.8-1.fc18.x86_64
Sep 19 16:56:17 Updated: vinagre-3.5.90-2.fc18.x86_64
Sep 19 16:56:22 Updated: eog-3.5.91-1.fc18.x86_64
Sep 19 16:56:24 Updated: baobab-3.5.91-1.fc18.x86_64
Sep 19 16:56:24 Updated: taglib-1.8-2.fc18.x86_64
Sep 19 16:56:25 Updated: firstboot-18.3-1.fc18.x86_64

Note You need to log in before you can comment on or make changes to this bug.