Bug 858764 - RFE: Support for non-docbook files (possibly new entity type).
RFE: Support for non-docbook files (possibly new entity type).
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.1
Assigned To: Lee Newson
:
Depends On:
Blocks: 909027 970452 970454
  Show dependency treegraph
 
Reported: 2012-09-19 12:00 EDT by Stephen Gordon
Modified: 2013-11-07 21:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 970452 970454 (view as bug list)
Environment:
Last Closed: 2013-11-07 21:13:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-09-19 12:00:28 EDT
Description of problem:

From time to time we produce documentation that includes files that are not docbook XML. Sometimes these will be binary files like music or video clips, sometimes they will be HTML output from tools like pydoc that don't speak DocBook XML.

Currently to include such material in a guide you add a files subdirectory under en-US, put the material there, and then link to it from the XML using a <ulink> tag.

This can also be done with topic based books, but you have to maintain the additional files outside of SkyNet. Ideally I think I would like to see a 'Files' entity in skynet where these can be uploaded, and to have ulinks that point to them based on ID (files/12331) automatically expanded for output. 

Additionally, particularly to support the API use case, it would be useful to be able to upload an archive of files and have it automatically server side (this would avoid having to manually upload each individual file if you are providing API docs for a lot of modules).
Comment 1 Lee Newson 2013-06-04 01:16:16 EDT
Added to the server in 1.1-SNAPSHOT build 20130503-1014

We've added the ability to store additional files that go in a books "files/" directory to the server. The structure is as follows:

A File has the following attributes:
 - File ID
 - File Name
 - File Path
 - Explode Archive
 - A collection of LanguageFile's

A LanguageFile has the following attributes:
 - LanguageFile ID
 - File ID
 - Locale
 - File Data

So this allows a user to upload a single file or an archive, along with specifying a custom path if required. It also allows the user to specify if the file is an archive, if it should be exploded when added to a book. Lastly it also allows Translations to be used for each File, in the same way that Images are used.
Comment 3 Lee Newson 2013-11-07 21:13:29 EST
Marking this as closed since it passed our teams testing and is currently live.

Note You need to log in before you can comment on or make changes to this bug.