Bug 858773 - subscription-manager-gui live filter segfaults when driven with ldtp test driver [NEEDINFO]
subscription-manager-gui live filter segfaults when driven with ldtp test driver
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgail-gnome (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 928849
  Show dependency treegraph
 
Reported: 2012-09-19 12:27 EDT by J.C. Molet
Modified: 2014-06-02 09:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:06:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (jmolet)


Attachments (Terms of Use)
install-ldtp.sh (1.75 KB, application/x-shellscript)
2012-09-19 12:28 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2012-09-19 12:27:39 EDT
Description of problem:
When changing the "contain the text" filter when searching for subscriptions, the gui crashes with the error "Segmentation fault".  This only happens when using the live text update, and changing the text REALLY fast.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.18-1.git.4.05607a2.el5

How reproducible:
somewhat

Steps to Reproduce:
1. start up Subscription-manager-gui 
2. register to your handy dandy candlepin server (TM)
3. go to the "All Available Subscriptions" tab
4. Click on filters, and uncheck everything, and put in any string in the "Contain the text" field
5. Close the filters
6. click 'update' to search for subscriptions
7. open filters again
8. Change the text filter very quickly, for example using superhuman typing skills or ldtp.settextvalue()

8a - using the python shell:
>>> import ldtp
>>> ldtp.settextvalue("Filter Options", "Text in Subscription", "AnyStringYouWantHere")

(see additional info for how to install ldtp)
  
Actual results:
subscription-manager-gui crashes with no error messages or logs other than "segmentation fault"

Expected results:
subscription-manager-gui does not crash and updates the search list

Additional info:
HOW TO INSTALL LDTP:
Make sure you have access to the the rhel channels via yum.

run my install-ldtp.sh script (attached).
Comment 1 J.C. Molet 2012-09-19 12:28:12 EDT
Created attachment 614468 [details]
install-ldtp.sh
Comment 2 RHEL Product and Program Management 2012-09-19 12:28:15 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Alex Wood 2012-09-25 14:31:23 EDT
Bad news.  It appears that this issue can be reproduced by hand by following a very specific set of steps.

1. Open subscription-manager, register, and go to the All Available Subscriptions tab.
2. Click Update.
3. Click Filters.
4. Uncheck the two checked filters.
5. Enter text in the text field.
6. Segfault.
Comment 4 Alex Wood 2012-09-26 10:47:34 EDT
It looks like the path to reproduce this issue is even more obscure that the one listed above.

In step 1 of comment #3, you must register to a Candlepin instance where no service level will cover the installed products.  I have been emulating this by using a Red Hat Enterprise Linux product certificate but registering to a development Candlepin instance populated with test data.
Comment 5 Alex Wood 2012-09-26 13:57:21 EDT
Sometimes step 5 in comment #3 will not cause a segfault.  In that case, close the filter dialog, hit Update again, reopen the filter dialog, highlight all the text in the search field with the mouse, and type something.  That should cause the segfault.
Comment 6 Alex Wood 2012-09-26 16:10:17 EDT
Also note that accessibility must be enabled in Gnome for this error to occur.

# gconftool-2 --set /desktop/gnome/interface/accessibility --type=boolean true
# init 3 && sleep 10 && init 5
Comment 7 Adrian Likins 2012-10-05 12:02:41 EDT
since:
- this seems to happen only with accessibility turned on
- a relatively specific series of events happens
- a relatively unused feature
- the bug fix is most likely going to be in gtk2/libgail

can we punt this to 6.4 (or probably 5.10, since it doesn't crash
on rhel6). 

Otherwise I'd suggest maybe just turning off the text filter 
if accessibility is turned on.
Comment 9 Bryan Kearney 2012-10-17 17:09:00 EDT
per comment 7, this should be moved to 5.10
Comment 12 RHEL Product and Program Management 2013-05-01 03:20:58 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2014-03-07 07:42:59 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 14 RHEL Product and Program Management 2014-06-02 09:06:35 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.