Bug 858809 - Version bump of perl-libwww-perl to 6.04
Version bump of perl-libwww-perl to 6.04
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-libwww-perl (Show other bugs)
6.5
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: perl-maint-list
BaseOS QE - Apps
: FutureFeature, Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 13:45 EDT by Philip Prindeville
Modified: 2016-11-30 11:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 03:11:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Prindeville 2012-09-19 13:45:14 EDT
Description of problem:

perl-libwww-perl hasn't been updated for 3 years. Newer versions support the PUT method, which would be nice to have.

Version-Release number of selected component (if applicable):

5.833-2.el6

How reproducible:

N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Petr Pisar 2012-09-20 03:11:03 EDT
Upstream change log since 5.833:

______________________________________________________________________________
2012-02-18  Release 6.04

Gisle Aas (4):
      Typo fix; envirionment [RT#72386]
      Implement $ua->is_online test
      Add separate option to enable the live jigsaw tests
      Merge pull request #10 from trcjr/master

Theodore Robert Campbell Jr (3):
      now with put and delete helpers
      updated POD
      unit tests for ua->put and ua->delete

Peter Rabbitson (1):
      These modules work with 5.8.1
_______________________________________________________________________________
2011-10-15  Release 6.03

Ville Skyttä (7):
      Link updates.
      Attribute documentation wording improvements.
      Don't parse robots.txt response content unless it's textual.
      Decode robots.txt response content before attempting to parse it.
      RobotUA robots.txt response parsing cleanups.
      Don't parse HEAD of robots.txt responses.
      Request handler doc grammar fixes.

Gisle Aas (6):
      Pass on HTTP/1.0 if set as request protocol
      Remove outdated docs (not touched since 1996 :-)
      Merge pull request #22 from madsen/RT67947-verify_hostname
      PERL_LWP_ENV_PROXY tweaks
      lwp-request didn't respect -H Content-type [RT#70488]
      lwp-request -H didn't allow repeated headers

Christopher J. Madsen (2):
      verify_hostname defaults to 0 if ssl_opts provided [RT#67947]
      Test verify_hostname setting

Bryan Cardillo (1):
      Fix expect header support to work with content refs.

Moritz Onken (1):
      add PERL_LWP_ENV_PROXY env variable to enable env_proxy globally

_______________________________________________________________________________
2011-03-27  Release 6.02

This is the release where we try to help the CPAN-toolchain be able to install
the modules required for https-support in LWP.  We have done this by unbundling
the LWP::Protocol::https module from the libwww-perl distribution.  In order to
have https support you now need to install (or depend on) 'LWP::Protocol::https'
and then this will make sure that all the prerequsite modules comes along.
See [RT#66838].

This release also removes the old http10 modules that has really been
deprecated since v5.60.  These should have been removed at the v6.00 jump, but
I forgot.


Christopher J. Madsen (1):
      Ignores env variables when ssl_opts provided [RT#66663]

Gisle Aas (4):
      Fix typo; Authen::NTLM [RT#66884]

Yury Zavarin (1):
      Support LWP::ConnCache->new(total_capacity => undef)

_______________________________________________________________________________
2011-03-09  Release 6.01

Add missing HTTP::Daemon dependency for the tests.

_______________________________________________________________________________
2011-03-08  Release 6.00

Unbundled all modules not in the LWP:: namespace from the libwww-perl
distribution.  The new broken out CPAN distribtions are File-Listing,
HTML-Form, HTTP-Cookies, HTTP-Daemon, HTTP-Date, HTTP-Message, HTTP-Negotiate,
Net-HTTP, and WWW-RobotRules.  libwww-perl-6 require these to be installed.

This release also drops the unmaintained lwp-rget script from the distribution.

Perl v5.8.8 or better is now required.  For older versions of perl please stay
with libwww-perl-5.837.

For https://... default to verified connections with require IO::Socket::SSL
and Mozilla::CA modules to be installed.  Old behaviour can be requested by
setting the PERL_LWP_SSL_VERIFY_HOSTNAME environment variable to 0.  The
LWP::UserAgent got new ssl_opts method to control this as well.

Support internationalized URLs from command line scripts and in the proxy
environment variables.

The lwp-dump script got new --request option.

The lwp-request script got new -E option, contributed by Tony Finch.

Protocol handlers and callbacks can raise HTTP::Response objects as exceptions.
This will abort the current request and make LWP return the raised response.
_______________________________________________________________________________
2010-09-20  Release 5.837

David E. Wheeler (1):
      Fix for Encode 2.40

Gisle Aas (2):
      Fix Perl syntax error in synopsis
      Allow ISO 8601 date strings when parsing Apache file listings
______________________________________________________________________________
2010-05-13  Release 5.836

Gisle Aas (1):
      Fix problem where $resp->base would downcase its return value
_______________________________________________________________________________
2010-05-05  Release 5.835

Gisle Aas (12):
      simple string can be simplified
      Make $mess->decoded_content remove XML encoding declarations [RT#52572]
      Don't allow saving to filenames starting with '.' suggested by server
      Avoid race between testing for existence of output file and opening the file
      Minor doc fixup -- wrongly ucfirsted word
      Use decoded_content in HTTP:Response synopsis [RT#54139]
      sun.com is no more. rip!
      Trivial layout tweak to reduce variable scope.
      Add 'make test_hudson' target
      Implement alt_charset parameter for decoded_content()
      Test decoding with different charset parameters
      lwp-download now needs the -s option to honor the Content-Disposition header

Ville Skyttä (9):
      Make LWP::MediaTypes::media_suffix case insensitive.
      Skip XML decoding tests if XML::Simple is not available.
      Documentation fixes.
      Fix m_media_type => "xhtml" matching.
      Make parse_head() apply to data: requests.
      Documentation spelling fixes.
      Documentation grammar fixes.
      Use $uri->secure in m_secure if available.
      Fix handling of multiple (same) base headers, and parameters in them.

Mark Stosberg (5):
      Strip out empty lines separated by CRLF
      Best Practice: avoid indirect object notation
      Speed up as_string by 4% by having _sorted_field_names return a reference
      Speed up scan() a bit. as_string() from this branch is now 6% faster
      Port over as_string() optimizations from HTTP::Headers::Fast

Tom Hukins (2):
      Link to referenced documentation.
      Update repository location.

Father Chrysostomos (1):
      Remove needless (and actually harmful) local $_

Sean M. Burke (1):
      "Perl & LWP" is available online
_______________________________________________________________________________
2009-11-21  Release 5.834

Gisle Aas (4):
      Check for sane default_headers argument [RT#50393]
      Add $ua->local_address attribute [RT#40912]
      Test that generation of boundary works [RT#49396]
      Page does not display the "standard" apache listing any more

Ville Skyttä (2):
      Remove unneeded executable permissions.
      Switch compression/decompression to use the IO::Compress/IO::Uncompress and
          Compress::Raw::Zlib family of modules.

Slaven Rezic (1):
      lwp-request should use stderr for auth [RT#21620]
------------


The request PUT method has been added in latest 6.04 version. Please note the libwww-perl has got major refactoring in version 6.00, the modules have been moved into several new standalone upstream packages. There were also changes how HTTPS module handles blocking I/O.

I consider the rebase to risky with possibility to break current user experience.

Please contact Red Hat support to evaluate your request properly.

I consider the

Note You need to log in before you can comment on or make changes to this bug.