Bug 858843 - [RFE] Anaconda mouse buttons for left-handed mouse config
[RFE] Anaconda mouse buttons for left-handed mouse config
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 15:11 EDT by Przemek Klosowski
Modified: 2012-09-20 15:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 14:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemek Klosowski 2012-09-19 15:11:13 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0
Build Identifier: 

Currently Anaconda uses the right mouse button. Left-handed people usually expect the left button to be the primary. There was a suggestion that Anaconda allows and processes any button as valid, but that would block forever any possibility of using multiple buttons in Anaconda, and make it behave differently from the system it is about to install.

There was a discussion of it on the development list, and I suggested an alternative, which was received warmly and I was asked to file an FFE. I propose the following pseudocode:

 on (button-1-press or button-2-press or button-3-press) of ok_button do:
  if (button-1-press) do:
    commit_changes()
  else
    ask_if_the_user_wants_to_change_the_mouse_handedness()
end;

It would be nice if that 'handedness' choice in Anaconda carried over to the installed system as the default setting.


Reproducible: Always
Comment 1 Brian Lane 2012-09-20 14:40:08 EDT
I think that the limited number of people who use a mirrored setup can live with it during the short time it takes to install.
Comment 2 John Florian 2012-09-20 15:59:39 EDT
Certainly, the 10% or so of us can live without this feature.  We (well, some) can also install Fedora without using anaconda at all, but use it because it "generally" makes things easier than doing so without.

I would have thought this to be a trivial and harmless feature to implement and am disappointed to see it dismissed so readily.

Note You need to log in before you can comment on or make changes to this bug.