This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 858844 - yumBase().update() breaks when specifying pkgname, version, and release
yumBase().update() breaks when specifying pkgname, version, and release
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.3
noarch Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
Patrik Kis
:
Depends On:
Blocks: 782183
  Show dependency treegraph
 
Reported: 2012-09-19 15:16 EDT by Matthew Gyurgyik
Modified: 2014-01-21 01:25 EST (History)
5 users (show)

See Also:
Fixed In Version: yum-3.2.29-31.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:12:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Various tests using yum 3.2.39 releases 17, 22, 30 (4.23 KB, text/plain)
2012-09-19 15:16 EDT, Matthew Gyurgyik
no flags Details

  None (edit)
Description Matthew Gyurgyik 2012-09-19 15:16:00 EDT
Created attachment 614554 [details]
Various tests using yum 3.2.39 releases 17, 22, 30

Description of problem:
yumBase().update() breaks when a pkgname, version, and release are passed.

Version-Release number of selected component (if applicable):
yum 3.2.29-22.el6 and 3.2.29-30.el6


How reproducible: Always


Steps to Reproduce:
1. import yum
2. yum.YumBase().update(name="fakepackage", version="1", release="1")
  
Actual results:

>>> yum.YumBase().update(name="fakepackage", version="1", release="1")
Loaded plugins: refresh-packagekit
Traceback (most recent call last):
File "<input>", line 1, in <module>
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3740, in update
self.logger.warning(_("No package matched to upgrade: %s"), self._ui_nevra_dict(nevra_dict))
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4352, in _ui_nevra_dict
evr = '%s-%s' % (e, v, r)


Expected results:

>>> yum.YumBase().update(name="fakepackage", version="1", release="1")
Loaded plugins: refresh-packagekit
[]


Additional info:
Attached you will find the output of various test case scenarios using yum 3.2.29 release 17, 22, and 30
Comment 2 James Antill 2012-09-20 10:12:57 EDT
Upstream commit: 7498c0878a3f804c55236a1c2af8463dee4ead4a
Comment 8 errata-xmlrpc 2013-02-21 05:12:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0406.html

Note You need to log in before you can comment on or make changes to this bug.