Bug 858860 - [abrt] yum-utils-1.1.31-4.fc17: shutil.py:83:copyfile:IOError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/Dropbox/repomd.xml.old.tmp'
[abrt] yum-utils-1.1.31-4.fc17: shutil.py:83:copyfile:IOError: [Errno 13] Per...
Status: CLOSED DUPLICATE of bug 830523
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:4442a670da183a1c0852ca7e4ff...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 16:32 EDT by mmclean2005
Modified: 2014-01-21 18:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 07:41:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mmclean2005 2012-09-19 16:32:48 EDT
Version-Release number of selected component:
yum-utils-1.1.31-4.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
cmdline:        /usr/bin/python -tt /usr/sbin/yumdb sync-force
kernel:         3.5.0-2.fc17.x86_64

backtrace:
:shutil.py:83:copyfile:IOError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/Dropbox/repomd.xml.old.tmp'
:
:Traceback (most recent call last):
:  File "/usr/sbin/yumdb", line 249, in <module>
:    main()
:  File "/usr/sbin/yumdb", line 245, in main
:    run_cmd(yb, args)
:  File "/usr/sbin/yumdb", line 169, in run_cmd
:    apkg = yb.pkgSack.searchPkgTuple(pkg.pkgtup)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 777, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 302, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 127, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 83, in retrieveAllMD
:    if repo._async and repo._commonLoadRepoXML(repo):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1324, in _commonLoadRepoXML
:    if self._latestRepoXML(local):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1293, in _latestRepoXML
:    oxml = self._saveOldRepoXML(local)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1151, in _saveOldRepoXML
:    shutil.copy2(local, old_local)
:  File "/usr/lib64/python2.7/shutil.py", line 128, in copy2
:    copyfile(src, dst)
:  File "/usr/lib64/python2.7/shutil.py", line 83, in copyfile
:    with open(dst, 'wb') as fdst:
:IOError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/Dropbox/repomd.xml.old.tmp'
:
:Local variables in innermost frame:
:src: '/var/cache/yum/x86_64/17/Dropbox/repomd.xml'
:dst: '/var/cache/yum/x86_64/17/Dropbox/repomd.xml.old.tmp'
:fsrc: <closed file '/var/cache/yum/x86_64/17/Dropbox/repomd.xml', mode 'rb' at 0x2215c90>
:fn: '/var/cache/yum/x86_64/17/Dropbox/repomd.xml.old.tmp'
:st: posix.stat_result(st_mode=33188, st_ino=5312, st_dev=64768L, st_nlink=1, st_uid=0, st_gid=0, st_size=951, st_atime=1344286371, st_mtime=1335412034, st_ctime=1344286181)
Comment 1 Zdeněk Pavlas 2012-09-21 07:41:00 EDT
Too bad Abrt does not report UID anymore.  Not sure if this is the case, but yumdb probably ran as non-root user, and since it tried to use root cache, probably cacheonly.  This is a Yum bug, very likely a dupe of 830523.

Could you find the version of Yum installed?  If it's yum-3.4.3-28.fc17+ I'll reopen this.

*** This bug has been marked as a duplicate of bug 830523 ***

Note You need to log in before you can comment on or make changes to this bug.