Bug 858861 - HP OfficeJet G85xi USB printer/scanner and other 1284.4 devices unusable
HP OfficeJet G85xi USB printer/scanner and other 1284.4 devices unusable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 16:35 EDT by William J. Eaton
Modified: 2012-10-02 12:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 12:33:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to hplip-3.12.6 to fix the bug (1.49 KB, patch)
2012-09-19 16:35 EDT, William J. Eaton
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1053953 None None None 2012-09-21 06:49:43 EDT

  None (edit)
Description William J. Eaton 2012-09-19 16:35:54 EDT
Created attachment 614585 [details]
Patch to hplip-3.12.6 to fix the bug

Description of problem:
HP OfficeJet G85xi and similar USB printers/scanners are not auto-detected, and are not usable after being added manually.  All printers that support the IEEE 1284.4 protocol over USB are believed affected.

Version-Release number of selected component (if applicable):
hplip-3.12.6-1.fc17.i686 (and corresponding gui, common, and libs packages).
hplip-3.12.9 may also be affected.

How reproducible:
Repeatable, tested using OfficeJet G85xi.

Steps to Reproduce:
1.  On Fedora 17 system with the above hplip packages installed, connect HP OfficeJet G85xi to computer using USB cable.
2.  Notice that nothing happens, the printer and scanner are not found.
3.  Manually add the printer using hp-setup.  The manual USB option is required.  The printer is then added to CUPS.
4.  Try to print to the printer or use the scanner.  Printing fails, and the scanner is not found by simple-scan.
  
Actual results:
The printer and scanner remain unusable.  Printing gives an error message in /var/log/messages like this, and the print job stalls.
Sep 17 15:46:19 localhost hpijs[2101]: io/hpmud/musb.c 1139: unable to open hp:/usb/OfficeJet_G85xi?serial=SGG11E0QQFVL

Expected results:
The printer and scanner should be detected and configured automatically.

Additional info:
lsusb -D shows this printer supports the IEEE 1284.4 protocol, code 3.
lsusb -D /dev/bus/usb/002/002
Device: ID 03f0:0311 Hewlett-Packard OfficeJet G85xi
(text omitted)
Interface Descriptor:
(text omitted)
bInterfaceProtocol      3 IEEE 1284.4 compatible bidirectional

Code in io/hpmud/musb.c only tests for codes 1 and 2.
A patch is included that appears to fix the problem.  The printer/scanner was detected correctly after applying this.
The same code appears to be present in hplip-3.12.9.
Comment 1 Jiri Popelka 2012-09-20 05:46:57 EDT
Amazing. Thank you for the patch.
Can you update to hplip-3.12.9-1.fc17 to make sure the problem is still there ?
You can find RPMs here:
https://koji.fedoraproject.org/koji/buildinfo?buildID=353057
and then please also test hplip-3.12.9-2.fc17 which has your patch applied
RPMs: https://koji.fedoraproject.org/koji/buildinfo?buildID=355415

I'm going to report the problem upstream (https://bugs.launchpad.net/hplip/+filebug). Or do you want to do it yourself ?
Comment 2 William J. Eaton 2012-09-20 14:31:55 EDT
(In reply to comment #1)
> Amazing. Thank you for the patch.
> Can you update to hplip-3.12.9-1.fc17 to make sure the problem is still
> there ?
> You can find RPMs here:
> https://koji.fedoraproject.org/koji/buildinfo?buildID=353057
> and then please also test hplip-3.12.9-2.fc17 which has your patch applied
> RPMs: https://koji.fedoraproject.org/koji/buildinfo?buildID=355415
> 
> I'm going to report the problem upstream
> (https://bugs.launchpad.net/hplip/+filebug). Or do you want to do it
> yourself ?

I tested the i686 binaries of the above.  As expected, the problem is still present in 3.12.9-1.fc17, and is fixed by 3.12.9-2.fc17.  Printer autoconfiguration, printing, and scanning via simple-scan all worked.

Please report this upstream.  Thank you.
Comment 3 Fedora Update System 2012-09-21 06:41:43 EDT
hplip-3.12.9-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hplip-3.12.9-2.fc18
Comment 4 Fedora Update System 2012-09-21 06:42:42 EDT
hplip-3.12.9-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-13619/hplip-3.12.9-2.fc17
Comment 5 Fedora Update System 2012-09-22 02:29:59 EDT
Package hplip-3.12.9-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.12.9-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14521/hplip-3.12.9-2.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-09-25 12:33:18 EDT
hplip-3.12.9-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-10-02 12:07:19 EDT
hplip-3.12.9-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/hplip-3.12.9-6.fc16

Note You need to log in before you can comment on or make changes to this bug.