Bug 858862 - "0 b free" reported for newly created qemu disk image
"0 b free" reported for newly created qemu disk image
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 16:39 EDT by Steve Tyler
Modified: 2012-11-22 21:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:21:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb-CoUhx3 (106.28 KB, text/plain)
2012-09-19 16:39 EDT, Steve Tyler
no flags Details
screenshot showing "0 b free" (56.10 KB, image/png)
2012-09-19 16:41 EDT, Steve Tyler
no flags Details
screenshot showing "No disks selected." (71.80 KB, image/png)
2012-09-19 16:42 EDT, Steve Tyler
no flags Details
screenshot showing "0 B" in "Free" column (46.77 KB, image/png)
2012-09-20 11:36 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-09-19 16:39:33 EDT
Created attachment 614586 [details]
anaconda-tb-CoUhx3

Description of problem:
When attempting to install to a newly created qemu disk image, the installer initially reports that the disk image has "0 b free" on it.

Version-Release number of selected component (if applicable):
anaconda 18.8
qemu-img-1.0.1-1.fc17.x86_64
qemu-kvm-1.0.1-1.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. On an F17 host, install F18 with a gnome desktop 
   to a 12G VM disk image and update.
2. On the F17 host, create an empty disk image for the install target:
   $ qemu-img create f18-test-2.img 10G
3. Restart the VM with the empty disk image as sdb:
   $ qemu-kvm -m 1024 -hda f18-test-1.img -hdb f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Alpha/RC3/Fedora-18-Alpha-x86_64-DVD.iso -vga qxl
4. From the F18 VM, install anaconda and start it from a terminal:
   $ sudo anaconda
5. For the installation destination, choose the 10G disk.
   The installer shows "0 b free" (see screenshot).
6. Click "Continue".
   The installer shows "1 storage device selected" and
   "No disks selected." (see screenshot).
  
Actual results:
See above.

Expected results:
The installer detects an empty qemu disk image as having all bytes free.
Such an image has all zeros:
$ dd if=f18-test-2.img | hexdump -C
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
20971520+0 records in
20971520+0 records out
10737418240 bytes (11 GB) copied, 26.3706 s, 407 MB/s
280000000

Additional info:
Comment 1 Steve Tyler 2012-09-19 16:41:19 EDT
Created attachment 614587 [details]
screenshot showing "0 b free"
Comment 2 Steve Tyler 2012-09-19 16:42:27 EDT
Created attachment 614588 [details]
screenshot showing "No disks selected."
Comment 3 Steve Tyler 2012-09-19 17:45:22 EDT
I should have said to check "Let me customize the partitioning ...".

On repeated trials, I have not seen "No disks selected.", as shown in the second screenshot.

The attached log file was generated with:
# kill -USR2 `cat /var/run/anaconda.pid`
from a second tab in the terminal.
Comment 4 Steve Tyler 2012-09-20 11:36:45 EDT
Created attachment 614962 [details]
screenshot showing "0 B" in "Free" column

Reproduced while running from the F18-Alpha-RC3 DVD (anaconda 18.6.8):

$ hexdump -C f18-test-2.img
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
280000000
$ qemu-kvm -m 1024 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Alpha/RC3/Fedora-18-Alpha-x86_64-DVD.iso -vga qxl --boot menu=on

anaconda 18.6.8

Click "Installation Destination"

Click "10.24 GB" disk.

"0 b free" is displayed at the lower-left.

Click:
"1 disk selected; 10.24 Gb capacity; 0 b free ..."

"Selected Disks" shows "0 B" in the "Free" column.
Comment 7 Chris Lumens 2012-09-25 17:08:03 EDT
Looks like one of the patches dlehman just posted should take care of this.
Comment 8 Fedora Update System 2012-09-26 19:01:49 EDT
anaconda-18.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.10-1.fc18
Comment 9 Fedora Update System 2012-09-27 20:19:36 EDT
Package anaconda-18.10-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.10-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14933/anaconda-18.10-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-10-02 10:13:08 EDT
anaconda-18.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.11-1.fc18
Comment 11 Fedora Update System 2012-10-03 20:58:03 EDT
anaconda-18.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.12-1.fc18
Comment 12 Adam Williamson 2012-11-22 21:21:52 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.