Bug 858890 - jai-imageio-core: Non-free license
jai-imageio-core: Non-free license
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: jai-imageio-core (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Goode
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 877050
  Show dependency treegraph
 
Reported: 2012-09-19 18:54 EDT by Mikolaj Izdebski
Modified: 2012-12-18 11:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 877050 (view as bug list)
Environment:
Last Closed: 2012-12-18 09:40:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-09-19 18:54:45 EDT
It's likely that jai-imageio-core may be non free.

Quoting from the COPYRIGHT.txt file: "Nuclear, missile, chemical biological weapons or nuclear maritime end uses or end users, whether direct or indirect, are strictly prohibited. [...] Les utilisations, ou utilisateurs finaux, pour des armes nucléaires, des missiles, des armes biologiques et chimiques ou du nucléaire maritime, directement ou indirectement, sont strictement interdites."
Comment 1 Adam Goode 2012-09-19 22:18:39 EDT
There was some discussion of the license during review:
http://www.redhat.com/archives/fedora-legal-list/2008-December/msg00003.html
Comment 2 Stanislav Ochotnicky 2012-09-20 04:10:25 EDT
(In reply to comment #1)
> There was some discussion of the license during review:
> http://www.redhat.com/archives/fedora-legal-list/2008-December/msg00003.html

That discussion was about different aspects. jai-imageio-core restricts its use for some cases. That is normally not allowed in Fedora. For example of other such cases see [1]. 


[1] http://fedoraproject.org/wiki/Licensing:Main#Bad_Licenses
Comment 3 Tom "spot" Callaway 2012-09-20 09:52:51 EDT
Yeah, that additional chunk of license is clearly non-free. 

That legal boilerplate is common in Sun stuff, but there is some precedence in having it changed, see:

http://java.net/jira/browse/JDIC-59

I'd go ahead and open a Jira issue for this one, the same fix as in JDIC-59 would resolve the issue, but I wonder if there is a good chance of success here, the code seems to have not had any SVN commits in 4 years...
Comment 4 Adam Goode 2012-10-12 20:50:13 EDT
Someone should decide if that file has bearing on the actual source files that are present in the SRPM. When I build the SRPM, I removed sources that were unpackagable because of non-free licenses. What is left was believed to be ok.

But, I no longer use this package. If it is easier to purge it from Fedora than spend time to investigate, that is fine by me.
Comment 5 Mikolaj Izdebski 2012-12-13 10:13:19 EST
What is the progress on this bug? This is a serious issue, as this package contains non-free software.

(In reply to comment #4)
> If it is easier to purge it from Fedora
> than spend time to investigate, that is fine by me.

In my opinion asking upstream about relicensing jai-imageio-core under a free software license is worth trying. I don't think that removing jai-imageio-core will be easy, as batik requires it to support raster graphics. Hundreds of packages (transitively) depend on jai-imageio-core.
Comment 6 Tom "spot" Callaway 2012-12-17 16:57:56 EST
Reread this, this is the "fixed" nuclear clause, because it says:

  You acknowledge that this software is not designed or intended for
  use in the design, construction, operation or maintenance of any
  nuclear facility.

The non-free original text said:

 You acknowledge that this software is not designed, licensed or
 intended for use in the design, construction, operation or
 maintenance of any nuclear facility.

The word "licensed" is the problem, and that word doesn't appear in the jai-imageio-core license. The current text is ugly, but does not actually mean a use restriction as worded. Closing this bug as NOTABUG.
Comment 7 Mikolaj Izdebski 2012-12-18 06:09:57 EST
(In reply to comment #6)
> The word "licensed" is the problem, and that word doesn't appear in the
> jai-imageio-core license. The current text is ugly, but does not actually
> mean a use restriction as worded. Closing this bug as NOTABUG.

What about the following sentence?

"Nuclear, missile, chemical biological weapons or nuclear maritime end uses or end users, whether direct or indirect, are strictly prohibited."

In my understanding the above sentence makes this software non-free. Some use cases are explicitly prohibited. Doesn't this mean a use restriction?
Comment 8 Tom "spot" Callaway 2012-12-18 09:40:46 EST
In the context that sentence appears, Sun is clearly restating their obligations under US Export law. This is not part of the license text (in license.txt).

Here it is in full context:

  This product is covered and controlled by U.S. Export Control laws and
  may be subject to the export or import laws in other countries.  
  Nuclear, missile, chemical biological weapons or nuclear maritime end
  uses or end users, whether direct or indirect, are strictly 
  prohibited.  Export or reexport to countries subject to U.S. embargo or 
  to entities identified on U.S. export exclusion lists, including, but 
  not limited to, the denied persons and specially designated nationals
  lists is strictly prohibited.

I know thats a bit confusing, but we don't treat this export boilerplate as a use restriction.
Comment 9 Mikolaj Izdebski 2012-12-18 11:44:54 EST
(In reply to comment #8)
> I know thats a bit confusing, but we don't treat this export boilerplate as
> a use restriction.

Thank you for explanation. Releasing block on FE-Legal.

Note You need to log in before you can comment on or make changes to this bug.