Bug 85891 - java / jvmsetup doesn't work
java / jvmsetup doesn't work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-10 08:00 EST by Mikael Carneholm
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 15:31:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
not works (40 bytes, text/plain)
2003-07-10 02:17 EDT, Nahum Castro
no flags Details

  None (edit)
Description Mikael Carneholm 2003-03-10 08:00:43 EST
Description of problem:
Running /usr/lib/openoffice/program/jvmsetup yields "Java cannot be configured"

Version-Release number of selected component (if applicable):
1.0.2

How reproducible:
Always.

Steps to Reproduce:
1. From a terminal, run /usr/lib/openoffice/program/jvmsetup
    
Actual results:
"Java cannot be configured"

Expected results:
The program should start and let me configure which jvm to use (I suppose)

Additional info:
As OOo is "pre-installed" and pre-configured in phoebe, the installation program
that normally detects what jvm to use will never be run and java will thus be
hard to setup without the help of jvmsetup. If a jvm was shipped with RH and OOo
was pre-configured to use this jvm this would not be an issue, but as long as
this is not the case you will have to install java post installing OOo and there
should thus be an easy way to make java work with OOo.
Comment 1 Nahum Castro 2003-07-10 02:17:12 EDT
Created attachment 92858 [details]
not works

On RedHat 8.0 the same problem exist, once a RedHat Engineer told me that they
not shipped Java so the jvmsetup will not work, but jvmsetup is just a file
with the next:
#/bin/sh
echo Java cannot be configured

So they (redhat) disabled or changed jvmsetup with a purpose unknow to me.

If you try to install OOo downloaded from www.openoffice.org the suite will not
work at all (crashes on startup). So the best solution to me is downgrade to RH
7.3 or change to Mandrake 9.1.
Comment 2 Dan Williams 2003-12-05 15:31:00 EST
Correct, Java is not enabled for the builds because we do not ship
Java with OOo.  We won't ship an SRPM that cannot be built on the base
system, that's just bad form.

However, with 1.1.0 I've added simple switch to flip in the specfile,
plus you point the specfile to your JDK, and thats it to get your
build with Java.  We are working on getting OOo to compile the Java
bits iwth GCJ, and when that is successful, then of course I'll turn
Java stuff back on.  Until then, you'll have to build Java support on
your own.

Note You need to log in before you can comment on or make changes to this bug.