Bug 858912 - Check if a stream is still open before flushing it
Check if a stream is still open before flushing it
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-concurrentloghandler (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Callaghan
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 856850
  Show dependency treegraph
 
Reported: 2012-09-19 22:14 EDT by Amit Saha
Modified: 2015-07-26 18:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 01:04:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Patch (784 bytes, patch)
2012-09-19 22:14 EDT, Amit Saha
no flags Details | Diff

  None (edit)
Description Amit Saha 2012-09-19 22:14:55 EDT
Created attachment 614660 [details]
Proposed Patch

Description of problem:

The release method doesn't check if the stream is still open before flushing it. This is incompatible with Python 2.7, since the stream may have already been closed in the close() method. 

Version-Release number of selected component (if applicable):

0.8.4-4

How reproducible:

Faced while using it in Beaker on Fedora 17. See https://bugzilla.redhat.com/show_bug.cgi?id=856850

Steps to Reproduce:
1. See above bug

  
Actual results:

Crashes the application citing cannot write to a closed file.


Expected results:

Sane shutdown of the logging system

Additional info:

http://bugs.python.org/issue15960
Comment 1 Fedora Update System 2012-09-19 23:22:41 EDT
python-concurrentloghandler-0.8.4-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-concurrentloghandler-0.8.4-7.fc18
Comment 2 Fedora Update System 2012-09-19 23:23:18 EDT
python-concurrentloghandler-0.8.4-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-concurrentloghandler-0.8.4-7.fc17
Comment 3 Fedora Update System 2012-09-19 23:24:22 EDT
python-concurrentloghandler-0.8.4-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-concurrentloghandler-0.8.4-7.fc16
Comment 4 Fedora Update System 2012-09-21 20:12:12 EDT
Package python-concurrentloghandler-0.8.4-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-concurrentloghandler-0.8.4-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14512/python-concurrentloghandler-0.8.4-7.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-25 12:34:07 EDT
python-concurrentloghandler-0.8.4-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-10-02 11:54:22 EDT
python-concurrentloghandler-0.8.4-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Dan Callaghan 2012-10-17 01:04:46 EDT
python-concurrentloghandler-0.8.4-7.fc17 is now stable.

Note You need to log in before you can comment on or make changes to this bug.