Bug 858980 - ibus-typing-booster setup is not enabled in gnome-control-center region, .desktop file is missing
ibus-typing-booster setup is not enabled in gnome-control-center region, .des...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 05:35 EDT by Mike FABIAN
Modified: 2013-01-09 20:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 06:23:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ibus-typing-booster-setup-disabled.png (361.64 KB, image/png)
2012-09-20 05:35 EDT, Mike FABIAN
no flags Details
ibus-typing-booster-setup-enabled.png (390.73 KB, image/png)
2012-09-24 16:34 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2012-09-20 05:35:32 EDT
Created attachment 614810 [details]
ibus-typing-booster-setup-disabled.png

Probably similar to bug#858757.

The icon with the wrench is disabled when "English - US(Hunspell)" is selected in “gnome-control-center region”.

See screenshot.
Comment 1 Mike FABIAN 2012-09-24 16:34:08 EDT
Created attachment 616716 [details]
ibus-typing-booster-setup-enabled.png

As the screenshot shows, the setup button becomes enabled if one
adds a desktop file "ibus-setup-en_US.desktop", which I did by
creating a symbolic link:

ibus-setup-en_US.desktop -> ibus-setup-typing-booster.desktop

[root@localhost applications]# cat ibus-setup-typing-booster.desktop
[Desktop Entry]
Name=IBus Typing Booster Setup
Comment=Set ibus-typing-booster Preferences
Exec=/usr/libexec/ibus-setup-typing-booster
Icon=/usr/share/ibus-typing-booster/icons/ibus-hunspell-table.svg
NoDisplay=true
Type=Application
StartupNotify=true
[root@localhost applications]# 

So one would need to create many symbolic links for the many
different languages ibus-typing-booster supports. Symlinks
because the contents would all be identical, there is
only one setup application /usr/libexec/ibus-setup-typing-booster
for all of them.

The same problem occurs for the m17n input methods:

gnome-control-center searchs for files like

    ibus-setup-m17n:t:latn-post.desktop

i.e. different files for all the input methods from m17n although all
of them have the same setup application
“/usr/libexec/ibus-setup-m17n”.

I think instead of creating all these symbolic links, it is probably
better to improve function

static GDesktopAppInfo *
setup_app_info_for_id (const gchar *id)
{
  GDesktopAppInfo *app_info;
  gchar *desktop_file_name;

  desktop_file_name = g_strdup_printf ("ibus-setup-%s.desktop", id);
  app_info = g_desktop_app_info_new (desktop_file_name);
  g_free (desktop_file_name);

  return app_info;
}

from gnome-region-panel-input.c and make it find the correct .desktop
file.
Comment 2 Mike FABIAN 2012-09-25 05:11:58 EDT
I added some debug output like this:

diff -ru gnome-control-center-3.5.92.orig/panels/region/gnome-region-panel-input.c gnome-control-center-3.5.92/panels/region/gnome-region-panel-input.c
--- gnome-control-center-3.5.92.orig/panels/region/gnome-region-panel-input.c   2012-09-17 14:08:34.000000000 +0200
+++ gnome-control-center-3.5.92/panels/region/gnome-region-panel-input.c        2012-09-25 10:07:07.542318393 +0200
@@ -342,11 +343,15 @@
           IBusEngineDesc *engine_desc = NULL;
           GDesktopAppInfo *app_info = NULL;
           gchar *display_name = NULL;
+          gchar *setup = NULL;
 
           engine_desc = g_hash_table_lookup (ibus_engines, id);
           if (engine_desc)
             {
               display_name = engine_get_display_name (engine_desc);
+              setup = ibus_engine_desc_get_setup (engine_desc);
+              printf ("mike id='%s' display_name='%s' setup='%s'\n", id, display_name, setup);
+              g_free (setup);
               app_info = setup_app_info_for_id (id);
 
               gtk_list_store_set (GTK_LIST_STORE (model), &iter,
gnome-control-center-3.5.92/panels/regionだけに発見: gnome-region-panel-input.c.~1~

And then I see:

[mfabian@localhost applications]$ gnome-control-center
mike id='en_US' display_name='English (English - US(Hunspell))' setup='/usr/libexec/ibus-setup-typing-booster'
mike id='anthy' display_name='Japanese (Anthy)' setup=''
mike id='m17n:hi:inscript' display_name='Hindi (inscript (m17n))' setup='/usr/libexec/ibus-setup-m17n --name m17n:hi:inscript'
mike id='libpinyin' display_name='Chinese (Intelligent Pinyin)' setup=''
mike id='m17n:t:latn-pre' display_name='Other (latn-pre (m17n))' setup='/usr/libexec/ibus-setup-m17n --name m17n:t:latn-pre'
mike id='m17n:t:latn-post' display_name='Other (latn-post (m17n))' setup='/usr/libexec/ibus-setup-m17n --name m17n:t:latn-post'
mike id='ipa-x-sampa' display_name='Other (ipa-x-sampa)' setup=''
mike id='latex' display_name='Other (latex)' setup=''
    
[mfabian@localhost gnome-control-center-3.5.92]$ 

So ibus-setup-m17n seems to need different options for
different engines.

If that is the case, one ibus-setup-m17n.desktop might not be enough,
one might need different files like

ibus-setup-m17n:t:latn-post.desktop
Comment 3 Rui Matos 2012-09-25 07:57:37 EDT
I'm not going to address your question directly because the issue seems bigger to me here.

We are still lacking a design for the input booster. I'm not at all convinced that the typing booster should be an "input source" like all the others. So, first we need a design and then we can tackle this kind of question.

Note that the typing booster isn't even white listed and the reason for that is exactly because we don't have a design for it.
Comment 4 Mike FABIAN 2012-09-26 02:24:29 EDT
(In reply to comment #3)
> I'm not going to address your question directly because the issue seems
> bigger to me here.
> 
> We are still lacking a design for the input booster. I'm not at all
> convinced that the typing booster should be an "input source" like all the
> others. 

Why not?

> So, first we need a design and then we can tackle this kind of
> question.

Do you have any idea about a design?
 
> Note that the typing booster isn't even white listed and the reason for that
> is exactly because we don't have a design for it.

Yes, I know that it is not white listed.

I want to open another bug for this because I think it is not a good
situation at the moment that some extremely useful are very hard to
access because they are not whitelisted and cannot be easily
enabled. They can be enabled with

   gsettings set org.gnome.desktop.input-sources show-all-sources true

but that is very hard to find. You told me it is not supposed to be found.
But how can one use input methods like ibus-typing-booster then?

And not only ibus-typing-booster, there are very useful
input methods like m17n:t:latn-pre m17n:t:latn-post which
are also not white listed and thus not easily available.
Comment 5 Parag Nemade 2012-09-26 02:40:25 EDT
Rui,
Seems to me a disappointing release f18 and work by upstream gnome people on input-sources. People who are testing IM are already getting a lot of confusion on how to start/use input-method. Evenif they manage to start IME there is no supportive options seen for that particular IME in keyboard indicator panel in F18 Alpha.

I will vote here for adding keymaps of a new Inscript2 standard developed by Indian Government.
Comment 6 Rui Matos 2012-09-27 13:02:55 EDT
BTW, this really is an upstream issue, I'd prefer if you filed these kind of things there. I'll leave it to you if you want to keep this bug report open.

(In reply to comment #4)
> (In reply to comment #3)
> > I'm not going to address your question directly because the issue seems
> > bigger to me here.
> > 
> > We are still lacking a design for the input booster. I'm not at all
> > convinced that the typing booster should be an "input source" like all the
> > others. 
> 
> Why not?

Because it's not a different keysym arrangement (i.e. a layout) neither is it something that transforms the symbols you type into another set of symbols (i.e. an engine like anthy).

> > So, first we need a design and then we can tackle this kind of
> > question.
> 
> Do you have any idea about a design?

I haven't thought hard enough about it but I think something like a checkbox in the UI like: [] Auto complete words

This kind of design would make it an option for every language even if currently it can't work with every language. For languages not supported yet we could gray out the checkbox and add a tip label explaining that the feature isn't available for the selected language.

> I want to open another bug for this because I think it is not a good
> situation at the moment that some extremely useful are very hard to
> access because they are not whitelisted and cannot be easily
> enabled. They can be enabled with
> 
>    gsettings set org.gnome.desktop.input-sources show-all-sources true
> 
> but that is very hard to find. You told me it is not supposed to be found.
> But how can one use input methods like ibus-typing-booster then?

My opinion is that we shouldn't be exposing half-baked features and since there isn't even a design for this feature...

> And not only ibus-typing-booster, there are very useful
> input methods like m17n:t:latn-pre m17n:t:latn-post which
> are also not white listed and thus not easily available.

I'll comment on the other bug about those, please don't mix too many subjects on the same bug report.

(In reply to comment #1)
> The same problem occurs for the m17n input methods:
> 
> gnome-control-center searchs for files like
> 
>     ibus-setup-m17n:t:latn-post.desktop
> 
> i.e. different files for all the input methods from m17n although all
> of them have the same setup application
> “/usr/libexec/ibus-setup-m17n”.

See https://bugzilla.gnome.org/show_bug.cgi?id=684935 .
Comment 7 Fedora Update System 2012-09-28 09:41:27 EDT
ibus-typing-booster-0.0.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.10-1.fc18
Comment 8 Fedora Update System 2012-09-28 09:49:27 EDT
ibus-typing-booster-0.0.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.10-1.fc17
Comment 9 Fedora Update System 2012-09-28 09:55:10 EDT
ibus-typing-booster-0.0.10-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.10-1.fc16
Comment 10 Fedora Update System 2012-09-28 13:19:47 EDT
Package ibus-typing-booster-0.0.10-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-0.0.10-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14999/ibus-typing-booster-0.0.10-1.fc18
then log in and leave karma (feedback).
Comment 11 Mike FABIAN 2012-10-01 03:06:46 EDT
(In reply to comment #6)
> I haven't thought hard enough about it but I think something like a checkbox
> in the UI like: [] Auto complete words
> 
> This kind of design would make it an option for every language even if
> currently it can't work with every language. For languages not supported yet
> we could gray out the checkbox and add a tip label explaining that the
> feature isn't available for the selected language.


Currently, if one uses ibus-typing-booster engine for say German, then
ibus-typing-booster can use m17n latn-post, m17n latn-pre, as
transliteration engines or a Keyboard layout which has all necessary
characters for German directly and then provide completions.

The above idea sort of reverses this, one uses latn-post, latn-pre
or a keyboard layout and then selects a checkbox to complete.

But a simple checkbox would not be enough then, because
for input methods like latn-post which support many languages
the question would arise for which language it should complete.
Comment 12 Matthias Clasen 2012-10-05 13:03:58 EDT
> Seems to me a disappointing release f18 and work by upstream gnome people on
> input-sources. 

Really ?! Rui has worked very hard and invested many late nights to accommodate feedback that we've received from the i18n team. 

> But a simple checkbox would not be enough then, because
> for input methods like latn-post which support many languages
> the question would arise for which language it should complete.

Thats exactly the reason why Rui said that we need to have a larger look at the desired user experience first, and come up with a well-designed solution.
Comment 13 Fedora Update System 2012-10-23 02:20:50 EDT
ibus-typing-booster-0.0.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.15-1.fc17
Comment 14 Fedora Update System 2012-10-23 02:23:46 EDT
ibus-typing-booster-0.0.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.15-1.fc18
Comment 15 Fedora Update System 2012-10-23 02:36:43 EDT
ibus-typing-booster-0.0.15-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.15-1.fc16
Comment 16 Fedora Update System 2012-10-25 02:14:30 EDT
ibus-typing-booster-0.0.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.16-1.fc18
Comment 17 Fedora Update System 2012-10-25 02:31:43 EDT
ibus-typing-booster-0.0.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.16-1.fc17
Comment 18 Fedora Update System 2012-10-25 02:47:38 EDT
ibus-typing-booster-0.0.16-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.16-1.fc16
Comment 19 Fedora Update System 2012-10-31 13:28:13 EDT
ibus-typing-booster-0.0.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.18-1.fc18
Comment 20 Fedora Update System 2012-10-31 13:41:01 EDT
ibus-typing-booster-0.0.18-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.18-1.fc16
Comment 21 Fedora Update System 2012-10-31 14:33:31 EDT
ibus-typing-booster-0.0.18-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.18-1.fc17
Comment 22 Fedora Update System 2012-11-08 11:04:51 EST
ibus-typing-booster-0.0.20-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.20-1.fc16
Comment 23 Fedora Update System 2012-11-08 11:23:56 EST
ibus-typing-booster-0.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.20-1.fc17
Comment 24 Fedora Update System 2012-11-08 11:41:52 EST
ibus-typing-booster-0.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.20-1.fc18
Comment 25 Parag Nemade 2012-11-09 00:12:08 EST
So when are we get a REAL stable release for this bug?
Comment 26 Fedora Update System 2012-11-12 08:47:43 EST
ibus-typing-booster-0.0.21-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.21-1.fc18
Comment 27 Fedora Update System 2012-11-12 09:08:57 EST
ibus-typing-booster-0.0.21-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.21-1.fc17
Comment 28 Fedora Update System 2012-11-12 09:23:49 EST
ibus-typing-booster-0.0.21-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.21-1.fc16
Comment 29 Fedora Update System 2012-11-15 02:12:08 EST
ibus-typing-booster-0.0.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.22-1.fc18
Comment 30 Fedora Update System 2012-11-15 02:40:48 EST
ibus-typing-booster-0.0.22-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.22-1.fc16
Comment 31 Fedora Update System 2012-11-15 02:58:58 EST
ibus-typing-booster-0.0.22-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.22-1.fc17
Comment 32 Fedora Update System 2012-11-23 09:00:06 EST
ibus-typing-booster-0.0.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.23-1.fc18
Comment 33 Fedora Update System 2012-11-23 10:32:54 EST
ibus-typing-booster-0.0.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.23-1.fc16
Comment 34 Fedora Update System 2012-11-23 11:16:52 EST
ibus-typing-booster-0.0.23-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.23-1.fc17
Comment 35 Fedora Update System 2012-11-28 06:23:22 EST
ibus-typing-booster-0.0.22-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 36 Fedora Update System 2012-11-28 06:34:44 EST
ibus-typing-booster-0.0.22-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 37 Fedora Update System 2012-11-29 01:46:03 EST
ibus-typing-booster-0.0.22-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 38 Fedora Update System 2012-12-05 01:55:29 EST
ibus-typing-booster-0.0.23-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 39 Fedora Update System 2012-12-05 01:59:37 EST
ibus-typing-booster-0.0.23-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 Fedora Update System 2012-12-05 02:14:26 EST
ibus-typing-booster-0.0.23-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.