This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 858983 - Nic driver change from bnx2 to e1000 after configured in vlan ENV.
Nic driver change from bnx2 to e1000 after configured in vlan ENV.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 05:47 EDT by shaochen
Modified: 2016-04-26 09:55 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Previously, changing network interface drivers from bnx2 to e1000 on VLAN tagged network interfaces would fail. The driver would revert to bnx2, and vendor information would no longer be displayed. This was because the VLAN tag changed the name of the interface, and the properties of the parent interface weren't parsed correctly. Now, the udev properties of the parent interface are used with the tagged interface, and the interface is populated with the correct vendor information. The bnx2 driver remains the selected driver instead of reverting to e1000.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:39:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bus.jpg (37.97 KB, image/jpeg)
2012-09-20 05:47 EDT, shaochen
no flags Details
bnx2.jpg (14.71 KB, image/jpeg)
2012-09-20 05:48 EDT, shaochen
no flags Details
e1000.jpg (15.44 KB, image/jpeg)
2012-09-20 05:49 EDT, shaochen
no flags Details

  None (edit)
Description shaochen 2012-09-20 05:47:55 EDT
Created attachment 614813 [details]
bus.jpg

Description of problem:
In vlan ENV, choose the bnx2 nic and configure it with dhcp, the nic driver change from bnx2 to e1000, and the vendor info will disappear. 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120913.0.el6_3

How reproducible:
100%

Steps to Reproduce:
1. TUI Install RHEV-H.
2. Enter Network detail page, focus on nic driver (The nic driver show as bnx2).
3. Configure the bnx2 nic with DHCP and vlan ID (e.g. 20)
4. Focus in nic driver and vendor info again.
5. Disable network and check the nic driver.
  
Actual results:
1. Nic driver change from bnx2 to e1000 after configured in vlan ENV.
2. Vendor info will disappear too.
3. The bnx2 driver will back after disable network.

Expected results:
Configured network in vlan should not affect nic driver.

Additional info:
Comment 1 shaochen 2012-09-20 05:48:37 EDT
Created attachment 614814 [details]
bnx2.jpg
Comment 2 shaochen 2012-09-20 05:49:05 EDT
Created attachment 614816 [details]
e1000.jpg
Comment 4 shaochen 2012-09-20 06:13:17 EDT
No such issue in RHEV-H 6.2 GA version, so it is a regression bug.
Comment 8 Fabian Deutsch 2012-10-12 09:50:07 EDT
This only happens if a vlanid is assigned to the nic.

The driver is correctly displayed when no vlanid is given.
Comment 26 errata-xmlrpc 2013-02-28 11:39:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.