Bug 858993 - error: cannot invoke setopt() - perform() is currently running
error: cannot invoke setopt() - perform() is currently running
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:6ef561fded550c97a604c856191...
:
: 865173 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 06:20 EDT by prueboblog
Modified: 2012-11-22 21:29 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:29:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (697 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: anaconda-tb (175.32 KB, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: environ (940 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: type (9 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: storage.log (49.84 KB, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: version (2 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: program.log (24.48 KB, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: product (6 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: syslog (68.11 KB, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: packaging.log (438 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: anaconda.log (1.90 KB, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: ks.cfg (262 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: release (24 bytes, text/plain)
2012-09-20 06:20 EDT, prueboblog
no flags Details
File: description (3.02 KB, text/plain)
2012-09-20 06:21 EDT, prueboblog
no flags Details
Screenshot of backtrace (40.18 KB, image/png)
2012-10-18 12:29 EDT, Orion Poplawski
no flags Details

  None (edit)
Description prueboblog 2012-09-20 06:20:27 EDT
Version-Release number of selected component:
anaconda-18.6.7

Additional info:
libreport version: 2.0.12
cmdline:        BOOT_IMAGE=/boot/upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade ks=hd:UUID=74bbf490-d575-4f23-982e-c45528ca3a55:/boot/upgrade/ks.cfg stage2=hd:UUID=74bbf490-d575-4f23-982e-c45528ca3a55:/boot/upgrade/squashfs.img
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64
Comment 1 prueboblog 2012-09-20 06:20:30 EDT
Created attachment 614824 [details]
File: ifcfg.log
Comment 2 prueboblog 2012-09-20 06:20:32 EDT
Created attachment 614825 [details]
File: anaconda-tb
Comment 3 prueboblog 2012-09-20 06:20:35 EDT
Created attachment 614826 [details]
File: environ
Comment 4 prueboblog 2012-09-20 06:20:37 EDT
Created attachment 614827 [details]
File: type
Comment 5 prueboblog 2012-09-20 06:20:39 EDT
Created attachment 614828 [details]
File: storage.log
Comment 6 prueboblog 2012-09-20 06:20:41 EDT
Created attachment 614829 [details]
File: version
Comment 7 prueboblog 2012-09-20 06:20:43 EDT
Created attachment 614830 [details]
File: program.log
Comment 8 prueboblog 2012-09-20 06:20:45 EDT
Created attachment 614831 [details]
File: product
Comment 9 prueboblog 2012-09-20 06:20:48 EDT
Created attachment 614832 [details]
File: syslog
Comment 10 prueboblog 2012-09-20 06:20:51 EDT
Created attachment 614833 [details]
File: hashmarkername
Comment 11 prueboblog 2012-09-20 06:20:53 EDT
Created attachment 614834 [details]
File: packaging.log
Comment 12 prueboblog 2012-09-20 06:20:55 EDT
Created attachment 614835 [details]
File: anaconda.log
Comment 13 prueboblog 2012-09-20 06:20:57 EDT
Created attachment 614836 [details]
File: ks.cfg
Comment 14 prueboblog 2012-09-20 06:20:59 EDT
Created attachment 614837 [details]
File: release
Comment 15 prueboblog 2012-09-20 06:21:00 EDT
Created attachment 614838 [details]
File: description
Comment 16 Chris Lumens 2012-10-10 22:27:39 EDT
*** Bug 865173 has been marked as a duplicate of this bug. ***
Comment 18 David Lehman 2012-10-12 10:32:31 EDT
I have a potential fix for this in my local repo.
Comment 19 Orion Poplawski 2012-10-15 13:25:04 EDT
I'm seeing this too with Beta TC4.
Comment 20 Fedora Update System 2012-10-16 23:07:54 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 21 Fedora Update System 2012-10-17 13:29:02 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 22 Fedora Update System 2012-10-17 22:36:53 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 23 Fedora Update System 2012-10-18 11:28:49 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 24 Orion Poplawski 2012-10-18 12:29:52 EDT
Created attachment 629551 [details]
Screenshot of backtrace

I'm still seeing this with 18.18 (from smoke11).
Comment 25 David Lehman 2012-10-18 13:34:33 EDT
(In reply to comment #24)
> Created attachment 629551 [details]
> Screenshot of backtrace
> 
> I'm still seeing this with 18.18 (from smoke11).

This is a different occurrence of the same type of problem. I have a patch for it.
Comment 26 Fedora Update System 2012-10-19 21:31:06 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 27 Orion Poplawski 2012-11-06 14:06:48 EST
I'm not seeing this with 18.24/TC7 any more.
Comment 28 Adam Williamson 2012-11-22 21:29:14 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.