Bug 859015 - SELinux is preventing /usr/bin/rhythmbox from read, write access on the blk_file sr0.
SELinux is preventing /usr/bin/rhythmbox from read, write access on the blk_f...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a5a3568a92dcda75aab9d194f38...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 07:16 EDT by Mihai Harpau
Modified: 2012-09-22 06:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 07:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-20 07:16 EDT, Mihai Harpau
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-20 07:16 EDT, Mihai Harpau
no flags Details

  None (edit)
Description Mihai Harpau 2012-09-20 07:16:02 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.5.3-1.fc17.x86_64

description:
:SELinux is preventing /usr/bin/rhythmbox from read, write access on the blk_file sr0.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rhythmbox should be allowed read write access on the sr0 blk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rhythmbox /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:removable_device_t:s0
:Target Objects                sr0 [ blk_file ]
:Source                        rhythmbox
:Source Path                   /usr/bin/rhythmbox
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           rhythmbox-2.97-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-146.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.3-1.fc17.x86_64 #1 SMP Wed Aug
:                              29 18:46:34 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-09-20 14:12:13 EEST
:Last Seen                     2012-09-20 14:12:13 EEST
:Local ID                      e29dd7e4-dd53-428d-9b81-84379b87f7e6
:
:Raw Audit Messages
:type=AVC msg=audit(1348139533.16:337): avc:  denied  { read write } for  pid=14309 comm="rhythmbox" name="sr0" dev="devtmpfs" ino=7324 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:removable_device_t:s0 tclass=blk_file
:
:
:type=SYSCALL msg=audit(1348139533.16:337): arch=x86_64 syscall=open success=no exit=EACCES a0=215e230 a1=802 a2=7fffa91ecf4c a3=9 items=0 ppid=1 pid=14309 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=rhythmbox exe=/usr/bin/rhythmbox subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: rhythmbox,mozilla_plugin_t,removable_device_t,blk_file,read,write
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t removable_device_t:blk_file { read write };
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t removable_device_t:blk_file { read write };
:
Comment 1 Mihai Harpau 2012-09-20 07:16:05 EDT
Created attachment 614851 [details]
File: type
Comment 2 Mihai Harpau 2012-09-20 07:16:08 EDT
Created attachment 614852 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-20 07:22:34 EDT
You will need to turn off the unconfined_mozilla_plugin_transition boolean using 

# setsebool -P unconfined_mozilla_plugin_transition 0
Comment 4 Daniel Walsh 2012-09-22 06:21:44 EDT
This looks like /dev/sr0 has the wrong label on it.

matchpathcon  /dev/sr0
/dev/sr0	system_u:object_r:removable_device_t:s0

Note You need to log in before you can comment on or make changes to this bug.