Bug 85909 - Can't change hsync from 60Hz on secondary display - Radeon Mobility 9000 (M9)
Can't change hsync from 60Hz on secondary display - Radeon Mobility 9000 (M9)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-10 13:11 EST by Mark Knutsen
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version: RHL 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-22 13:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified XF86Config file (3.08 KB, text/plain)
2003-03-10 13:12 EST, Mark Knutsen
no flags Details
XFree86 logfile (40.76 KB, text/plain)
2003-03-10 13:13 EST, Mark Knutsen
no flags Details

  None (edit)
Description Mark Knutsen 2003-03-10 13:11:04 EST
Description of problem:
A fresh phoebe3 install works very well on my new used Dell Inspiron 8200 with
Radeon Mobility 9000, thanks to the new XFree86.

However, with the laptop closed and docked in the port replicator, I can't get
an external CRT to sync at anything other than 60Hz. This interacts badly with
the fluorescent lights around here.

I tried to change the Monitor section of the XF86Config file to reflect the
stats of the CRT, to no avail.

Version-Release number of selected component (if applicable):
4.2.99.901-20030213.0

How reproducible:
Always

Steps to Reproduce:
1. Fresh phoebe3 install, select Everything. LCD is 1600x1200.
2. Note external CRT displays at eyestrain-inducing 60Hz
3. Change Monitor section of XF86Config to reflect stats of external (Dell P991)
   CRT rather than internal (Dell UltraSharp 15") LCD.
4. Rerun X or reboot
    
Actual results:
No change, still 60Hz

Expected results:
Should drive the external display at 75Hz or better.

Additional info:
Will append complete files, but here's the relevant part of XF86Config:

  Section "Monitor"
  #	Option	    "dpms"
  	Identifier   "Monitor0"
  	VendorName   "Monitor Vendor"
  	ModelName    "Dell P991"
  	HorizSync    30.0 - 95.0
  	VertRefresh  50.0 - 160.0
  EndSection

And of the log:

  (II) RADEON(0): Clone modes validation ------------ 
  (II) RADEON(0): DDC detection (type 3) for clone modes
  (WW) RADEON(0): Monitor0: Using default hsync range of 28.00-33.00kHz
  (WW) RADEON(0): Monitor0: using default vrefresh range of 43.00-72.00Hz
  (II) RADEON(0): Clock range:  20.00 to 350.00 MHz
  ...
  (EE) RADEON(0): Virtual height (0) is too small for the hardware (min 128)
  (EE) RADEON(0): No valid mode found for CRTC2 clone
  (II) RADEON(0): Total of -1 clone modes found ------------ 

I also tried setting the "CloneVRefresh" and "DDCMode" driver options, but that 
didn't change the results.
Comment 1 Mark Knutsen 2003-03-10 13:12:59 EST
Created attachment 90543 [details]
Modified XF86Config file
Comment 2 Mark Knutsen 2003-03-10 13:13:38 EST
Created attachment 90544 [details]
XFree86 logfile
Comment 3 Todd Booher 2003-03-10 14:10:44 EST
I've seen a simliar problem with an IBM T30 plugged in to 
a docking station.  The refresh rate would not go over 60hz
on the external monitor.
Comment 4 Mike A. Harris 2003-03-12 08:21:19 EST
Sounds more like a configuration problem to me rather than an XFree86 bug.

Could you report this issue to the xfree86@xfree86.org mailing list first,
and see what other developers think about this whom might have such hardware
available to them for testing purposes (I do not have any laptop hardware
available for testing/troubleshooting).

If an XFree86 developer can acknowledge this as a bug, then perhaps it can
be investigated further.
Comment 5 Mark Knutsen 2003-03-24 16:47:30 EST
The correct diff from the installed XF86Config is as follows:

104a105,106
>       Option      "CloneHSync" "30.0-95.0"
>       Option      "CloneVRefresh" "50.0-160.0"
114c116
<               
Modes    "1600x1200" "1400x1050" "1280x1024" "1280x960" "1024x768" "800x600" "64
0x480"
---
>               Modes    "1600x1200"

The above gets me 75Hz @ 1600x1200 on my external display.

I initially had problems with CloneHSync and CloneVRefresh because I had spaces 
around the dash characters. This apparently isn't allowed in the radeon driver 
options; don't know yet if that's considered a bug. Note that the installer put 
spaces around the dashes in the HorizSync and VertRefresh lines; are you sure 
that's OK?

Note You need to log in before you can comment on or make changes to this bug.