Bug 859103 - vdsm: VM disk/cpu stat collection failures flood vdsm.log
vdsm: VM disk/cpu stat collection failures flood vdsm.log
Status: CLOSED DUPLICATE of bug 853725
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Saveliev Peter
Haim
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 10:46 EDT by Yaniv Kaul
Modified: 2014-01-12 19:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-29 10:10:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (2.30 MB, application/x-xz)
2012-09-20 10:48 EDT, Yaniv Kaul
no flags Details

  None (edit)
Description Yaniv Kaul 2012-09-20 10:46:17 EDT
Description of problem:
[root@gold-vdsd vdsm]# grep -c -E "_getDiskStats|_getCpuStats|getDiskLatency" /var/log/vdsm/vdsm.log
130349
[root@gold-vdsd vdsm]# wc -l /var/log/vdsm/vdsm.log
327082 /var/log/vdsm/vdsm.log

About 1/3 of the log file is flooded with events such as:
Thread-19421::DEBUG::2012-09-20 03:41:05,575::libvirtvm::243::vm.Vm::(_getDiskStats) vmId=`a760141e-2bc0-49d2-81fa-fc58e2a85bd8`::Disk hdc stats not available
Thread-19421::DEBUG::2012-09-20 03:41:05,575::libvirtvm::243::vm.Vm::(_getDiskStats) vmId=`a760141e-2bc0-49d2-81fa-fc58e2a85bd8`::Disk hda stats not available
Thread-19421::DEBUG::2012-09-20 03:41:05,576::libvirtvm::272::vm.Vm::(_getDiskLatency) vmId=`a760141e-2bc0-49d2-81fa-fc58e2a85bd8`::Disk hdc latency not available
Thread-19421::DEBUG::2012-09-20 03:41:05,576::libvirtvm::272::vm.Vm::(_getDiskLatency) vmId=`a760141e-2bc0-49d2-81fa-fc58e2a85bd8`::Disk hda latency not available


Version-Release number of selected component (if applicable):
vdsm-4.9.6-34.0.el6_3.x86_64
libvirt-0.9.10-21.el6_3.4.x86_64

How reproducible:
Not sure. Seen it on several logs.

Steps to Reproduce:
1. Look at vdsm.log - found it on several setups
2.
3.
  
Actual results:


Expected results:


Additional info:

Setting as regression - never seen that in 3.0.
Comment 1 Yaniv Kaul 2012-09-20 10:48:25 EDT
Created attachment 614946 [details]
vdsm.log
Comment 3 Yaniv Kaul 2012-09-27 16:00:30 EDT
Dup of https://bugzilla.redhat.com/show_bug.cgi?id=853725 ?
Comment 4 Ayal Baron 2012-09-29 10:10:15 EDT
(In reply to comment #3)
> Dup of https://bugzilla.redhat.com/show_bug.cgi?id=853725 ?

yes

*** This bug has been marked as a duplicate of bug 853725 ***

Note You need to log in before you can comment on or make changes to this bug.