Bug 859192 - Beginning of installation on x3270 console could look better
Beginning of installation on x3270 console could look better
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
s390x Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2012-09-20 14:56 EDT by Jan Stodola
Modified: 2013-01-10 01:55 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 15:06:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2012-09-20 14:56:18 EDT
Description of problem:
When starting installation on s390x, anaconda prints following on x3270 console:

...
         Starting Terminate Plymouth Boot Screen...   
         Starting Wait for Plymouth Boot Screen to Quit...   
         Starting Network Manager...   
 %G 
 [m  [?1l > [H [J [1;1HStarting installer, one moment... [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [7m[anaconda] 1:main* 2:shell  3:log  4:storage-log  5:program-log             
     [m  [24;1H [1;24r [H  
 [1;23r [H  
18:22:23 Please ssh install@xxxx.xxxx.xxx.redhat.com (10.16.105.196) to begin th
e install. [1;24r [H [3;11H  
 [1;23r [H [23;1H [1mPane is dead [H [m 18:22:23 Please ssh install@xxxx.xxxx.xx
x.redhat.com (10.16.105.196) to begin the install. [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [K  
 [1mPane is dead [m  [K [1;24r [H [23;13H


It doesn't look very nice and it's hard to read useful information. Compare it with nice-looking RHEL6 messages:


...
Initial configuration completed. 
 
Starting sshd to allow login over the network. 
 
Connect now to xx.xx.xxx.xxx and log in as user 'install' to start the installat
ion. 
E.g. using: ssh -x install@xx.xx.xxx.xxx 
For VNC or text mode, disable X11 forwarding (recommended) with 'ssh -x'. 
For X11, enable X11 forwarding with 'ssh -X'. 
 
You may log in as the root user to start an interactive shell. 




Version-Release number of selected component (if applicable):
anaconda-18.8

How reproducible:
always

Steps to Reproduce:
1. start installation on x3270 console
2. wait for further information how to continue with the installation
  
Actual results:
Too verbose anaconda on x3270 console

Expected results:
Anaconda prints only useful information
Comment 2 Martin Sivák 2012-09-20 15:03:08 EDT
I suppose this is caused by tmux.. can you try text mode anaconda (not ssh, just plain text) if it does the same?
Comment 3 Jan Stodola 2012-09-21 04:36:57 EDT
The only way (I'm aware of) how to run installation without using ssh is automated kickstart installation.

When running text or vnc mode installation manually, you start the installation on x3270 console, anaconda starts sshd and once you login via ssh, the installation continues via ssh session.

I've also tried starting the installer with "inst.text" boot option, but there is no difference in behaviour comparing to the initial description in comment 0.


Btw, when text mode installation starts via ssh, anaconda is not running in tmux, which means you cannot switch to tmux windows with shell and anaconda logs. Is this intended behaviour?

[anaconda root@rtt5 ~]# ps axf
...
    1 ?        Ss     0:08 /usr/lib/systemd/systemd --switched-root --system --deserialize 21
  975 ?        Ss     0:00 /usr/lib/systemd/systemd-udevd
 1050 ?        Ss     0:02 /usr/lib/systemd/systemd-journald
 1147 ?        Ssl    0:00 /sbin/rsyslogd -n -c 5
 1154 ?        Ssl    0:00 /usr/sbin/NetworkManager --no-daemon
 1157 hvc0     Ss+    0:00 /bin/bash --login
 1166 ?        Ssl    0:00 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
 1169 ?        Ssl    0:00 /usr/lib/polkit-1/polkitd --no-debug
 1176 ?        S      0:00 /usr/sbin/modem-manager
 1209 ?        Ss     0:00 /usr/sbin/sshd -D -f /etc/ssh/sshd_config.anaconda
 1228 ?        Ss     0:00  \_ sshd: install@pts/0                                  
 1230 pts/0    Ss+    0:05  |   \_ /usr/bin/python /sbin/anaconda
 1526 ?        Ss     0:00  \_ sshd: root@pts/5                                     
 1586 pts/5    Ss     0:00      \_ -bash
 1850 pts/5    R+     0:00          \_ ps axf
 1212 ?        Ss     0:00 /usr/bin/tmux -u -f /usr/share/anaconda/tmux.conf start
 1214 pts/1    Ss+    0:00  \_ bash --login
 1215 pts/2    Ss+    0:00  \_ tail -F /tmp/anaconda.log
 1216 pts/3    Ss+    0:00  \_ tail -F /tmp/storage.log
 1217 pts/4    Ss+    0:00  \_ tail -F /tmp/program.log
 1227 ttyS0    Ss+    0:00 /usr/bin/tmux -u attach -t anaconda
 1232 pts/0    S+     0:00 /sbin/auditd
Comment 4 Jesse Keating 2012-09-21 14:03:15 EDT
No, the behaviour of text mode on s390 and of ssh on s390 is not yet defined.  We had hoped tmux would work, but it appears that it cannot really handle the x3270 environment.  We also hoped to eliminate the need to ssh in to start the install, and instead we've designed the text mode interface to work within x3270, although even that needs some work.

Basically it's a work in progress.
Comment 5 Jesse Keating 2012-10-16 15:06:45 EDT
This is now fixed.

Note You need to log in before you can comment on or make changes to this bug.