Bug 859206 - RHC Feature tests need to create a user when running under origin
RHC Feature tests need to create a user when running under origin
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Test Suite (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Fotios Lindiakos
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 15:34 EDT by John (J5) Palmieri
Modified: 2015-05-14 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-09 14:34:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John (J5) Palmieri 2012-09-20 15:34:30 EDT
Description of problem:

RHC Feature tests fail under Origin due to needing the tests to register a user before running.  What needs to be added -

 * RHC_REGISTER_USER env var needs to be checked by the runner in rhc/features/support/env.rb
 * init stage needs to create a user on server based on $username, $password
 * li/build/origin script needs to be updated to pass RHC_REGISTER_USER to the tests
Comment 1 Fotios Lindiakos 2012-09-24 21:16:18 EDT
I added flags for the rhc cucumber tests as well as to the origin test scripts. I do not know how I can test this, so I am marking it as MODIFIED and pinging agupta to try the changes (he was the original reporter of the problem).

Associated branches are here:
https://github.com/fotioslindiakos/rhc/tree/BZ859206
https://github.com/fotioslindiakos/li/tree/BZ859206

NOTE: The li branch was based off the code before clayton's refactor. Since the master branch is being frozen, the code will have to be merged in another pull request against the new master. I did it this way so it can be tested before that refactor goes live. This code should not have any problems since it is isolated.
Comment 2 Peter Ruan 2012-10-22 12:26:43 EDT
still waiting for origin build to work in Fedora16.  Will test this once that is ready.
Comment 3 Clayton Coleman 2012-11-09 14:34:55 EST
Origin should run in a no-security mode in the test environment, rendering this bug unnecessary.  We'll track this by ensuring the tests are run in Origin outside of bugzilla.

Note You need to log in before you can comment on or make changes to this bug.