Bug 859211 - [abrt] evince-3.4.0-2.fc17: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
[abrt] evince-3.4.0-2.fc17: Process /usr/bin/evince was killed by signal 11 (...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: djvulibre (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
abrt_hash:2d28fc2de0d4179ce0ce7696849...
:
: 859213 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 15:44 EDT by aupr
Modified: 2012-12-11 01:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 01:01:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: environ (1.40 KB, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File: backtrace (32.62 KB, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File: cgroup (127 bytes, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File: maps (37.06 KB, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File: dso_list (8.10 KB, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File: var_log_messages (403 bytes, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File: open_fds (733 bytes, text/plain)
2012-09-20 15:44 EDT, aupr
no flags Details
File that cause a program crash (25.06 MB, application/octet-stream)
2012-10-03 03:27 EDT, aupr
no flags Details

  None (edit)
Description aupr 2012-09-20 15:44:10 EDT
Description of problem:
I was trying to open djvu file named "Котеров,Костарев - PHP 5.2ed.2009.djvu"  and also, another file with name "- PHP 5.2ed.2009.djvu" (this file are from differrent locations — one from my home directory and another from my second HDD).
With 10 other djvu files all is fine.


Version-Release number of selected component:
evince-3.4.0-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        evince '/mnt/bad/tmp/PHP5_2izd_koterov/- PHP 5.2ed.2009.djvu'
kernel:         3.5.3-1.fc17.x86_64
Comment 1 aupr 2012-09-20 15:44:15 EDT
Created attachment 615087 [details]
File: environ
Comment 2 aupr 2012-09-20 15:44:19 EDT
Created attachment 615088 [details]
File: limits
Comment 3 aupr 2012-09-20 15:44:25 EDT
Created attachment 615089 [details]
File: backtrace
Comment 4 aupr 2012-09-20 15:44:28 EDT
Created attachment 615090 [details]
File: cgroup
Comment 5 aupr 2012-09-20 15:44:35 EDT
Created attachment 615091 [details]
File: maps
Comment 6 aupr 2012-09-20 15:44:39 EDT
Created attachment 615092 [details]
File: dso_list
Comment 7 aupr 2012-09-20 15:44:42 EDT
Created attachment 615093 [details]
File: var_log_messages
Comment 8 aupr 2012-09-20 15:44:45 EDT
Created attachment 615094 [details]
File: open_fds
Comment 9 Marek Kašík 2012-10-02 04:38:12 EDT
*** Bug 859213 has been marked as a duplicate of this bug. ***
Comment 10 Marek Kašík 2012-10-02 04:39:17 EDT
This looks like a problem in djvulibre. I'm reassigning this.
Comment 11 Jonathan Underwood 2012-10-02 08:23:29 EDT
Can you please attach one of the files that is giving you a problem?
Comment 12 Jonathan Underwood 2012-10-02 08:28:03 EDT
Also, what happens if you open the file with djview4 ?
Comment 13 aupr 2012-10-02 15:33:50 EDT
No problems with djview4. I can attach file but later.
Comment 14 aupr 2012-10-03 03:27:02 EDT
Created attachment 620647 [details]
File that cause a program crash
Comment 15 Fedora Update System 2012-10-07 20:04:29 EDT
djvulibre-3.5.25.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/djvulibre-3.5.25.3-1.fc18
Comment 16 Fedora Update System 2012-10-07 20:23:34 EDT
djvulibre-3.5.25.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/djvulibre-3.5.25.3-1.fc17
Comment 17 Jonathan Underwood 2012-10-07 20:25:23 EDT
I've updated the djvulibre package to the latest upstream version - please test with these.

However, since djview4 opens these files without issue, I think the bug lies in the way evince is using the library.
Comment 18 Fedora Update System 2012-10-08 11:27:58 EDT
Package djvulibre-3.5.25.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing djvulibre-3.5.25.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15621/djvulibre-3.5.25.3-1.fc18
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-11-07 06:41:36 EST
djvulibre-3.5.25.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/djvulibre-3.5.25.3-2.fc18
Comment 20 Fedora Update System 2012-12-11 01:01:53 EST
djvulibre-3.5.25.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.