Bug 859214 - If s-c-d uses /etc/sysconfig/clock, please drop support for it
If s-c-d uses /etc/sysconfig/clock, please drop support for it
Status: CLOSED DUPLICATE of bug 824033
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 15:53 EDT by Lennart Poettering
Modified: 2012-10-22 08:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 08:27:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2012-09-20 15:53:39 EDT
/etc/localtime is now a symlink, from which the chosen timezone name is easily readable via readlink(). /etc/sysconfig/clock is hence obsolete. Please drop any usage, or creation of it, if s-c-d is still using it. thanks!
Comment 1 Nils Philippsen 2012-10-22 08:27:43 EDT
I've changed s-c-date so that it only uses /etc/sysconfig/clock if /etc/localtime is not usable for this (e.g. isn't a symlink, points to somewhere outside of /usr/share/zoneinfo). The next version in Rawhide/F-18 should have this fixed.

*** This bug has been marked as a duplicate of bug 824033 ***

Note You need to log in before you can comment on or make changes to this bug.