Bug 859237 - Deleting systems does not update the systems count
Deleting systems does not update the systems count
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Jakub Hadvig
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 17:05 EDT by Og Maciel
Modified: 2014-03-18 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (32.17 KB, image/png)
2012-09-20 17:05 EDT, Og Maciel
no flags Details
post deleting multiple system (99.55 KB, image/png)
2012-10-04 09:02 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Og Maciel 2012-09-20 17:05:26 EDT
Created attachment 615125 [details]
Screenshot

Description of problem:

Deleting systems (tried multiple at a time) from an organization in the System's tab does not update the total count. The (attached) screenshot shows that no systems are listed but the total count shows 13 systems registered. It was only after I switched tabs (from All to By Environments for instance) that the total count was updated.

Version-Release number of selected component (if applicable):

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-7.el6cf.noarch
* katello-all-1.1.12-7.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-4.el6cf.noarch
* katello-cli-common-1.1.8-4.el6cf.noarch
* katello-common-1.1.12-7.el6cf.noarch
* katello-configure-1.1.9-3.el6cf.noarch
* katello-glue-candlepin-1.1.12-7.el6cf.noarch
* katello-glue-pulp-1.1.12-7.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch

How reproducible:


Steps to Reproduce:
1. Delete multiple registered systems from your organization
2.
3.
  
Actual results:

The total systems count does not change

Expected results:

It should decrease by the correct number of systems deleted

Additional info:
Comment 3 Kedar Bidarkar 2012-10-04 09:02:30 EDT
Created attachment 621635 [details]
post deleting multiple system
Comment 4 Jakub Hadvig 2012-11-19 09:18:21 EST
Also when deleting system with CLI the counts won't update
Comment 5 Jason E. Rist 2012-11-19 10:09:42 EST
It would be great if this could be solved more universally as part of the pull notification that we do every x seconds. (get new notices).  Let's defer as part of nutupane work.
Comment 6 Mike McCune 2013-08-16 14:19:32 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 7 Mike McCune 2014-03-18 13:38:25 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.