Bug 859268 - bits/byteswap-16.h: No such file or directory
bits/byteswap-16.h: No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 20:18 EDT by nucleo
Modified: 2016-11-24 10:37 EST (History)
9 users (show)

See Also:
Fixed In Version: glibc-2.16.90-13.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 03:13:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2012-09-20 20:18:07 EDT
Description of problem:
libkipi build failed in Rawhide with error in glibc-headers.
https://koji.fedoraproject.org/koji/buildinfo?buildID=355555

Version-Release number of selected component (if applicable):
glibc-2.16.90-12.fc19

Actual results:
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec3611003202.dir/build.make CMakeFiles/cmTryCompileExec3611003202.dir/build
gmake[1]: Entering directory `/builddir/build/BUILD/libkipi-4.9.50/x86_64-redhat-linux-gnu/CMakeFiles/CMakeTmp'
/usr/bin/cmake -E cmake_progress_report /builddir/build/BUILD/libkipi-4.9.50/x86_64-redhat-linux-gnu/CMakeFiles/CMakeTmp/CMakeFiles 1
Building CXX object CMakeFiles/cmTryCompileExec3611003202.dir/check_qt_visibility.cpp.o
/usr/bin/c++    -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden   -I/usr/include/phonon -I/usr/include/QtXmlPatterns -I/usr/include/QtXml -I/usr/include/QtWebKit -I/usr/include/QtUiTools -I/usr/include/QtTest -I/usr/include/QtSvg -I/usr/include/QtSql -I/usr/include/QtScriptTools -I/usr/include/QtScript -I/usr/include/QtOpenGL -I/usr/include/QtNetwork -I/usr/include/QtMultimedia -I/usr/include/QtHelp -I/usr/include/QtDesigner -I/usr/include/QtDeclarative -I/usr/include/QtDBus -I/usr/include/Qt3Support -I/usr/include/QtGui -I/usr/include/QtCore -I/usr/include/Qt -I/usr/lib64/qt4/mkspecs/default    -o CMakeFiles/cmTryCompileExec3611003202.dir/check_qt_visibility.cpp.o -c /builddir/build/BUILD/libkipi-4.9.50/x86_64-redhat-linux-gnu/CMakeTmp/check_qt_visibility.cpp
In file included from /usr/include/endian.h:60:0,
                 from /usr/include/bits/waitstatus.h:64,
                 from /usr/include/stdlib.h:42,
                 from /usr/lib/gcc/x86_64-redhat-linux/4.7.2/../../../../include/c++/4.7.2/cstdlib:66,
                 from /usr/lib/gcc/x86_64-redhat-linux/4.7.2/../../../../include/c++/4.7.2/bits/stl_algo.h:61,
                 from /usr/lib/gcc/x86_64-redhat-linux/4.7.2/../../../../include/c++/4.7.2/algorithm:63,
                 from /usr/include/QtCore/qglobal.h:68,
                 from /usr/include/QtCore/QtGlobal:1,
                 from /builddir/build/BUILD/libkipi-4.9.50/x86_64-redhat-linux-gnu/CMakeTmp/check_qt_visibility.cpp:1:
/usr/include/bits/byteswap.h:34:30: fatal error: bits/byteswap-16.h: No such file or directory
compilation terminated.
gmake[1]: Leaving directory `/builddir/build/BUILD/libkipi-4.9.50/x86_64-redhat-linux-gnu/CMakeFiles/CMakeTmp'
gmake[1]: *** [CMakeFiles/cmTryCompileExec3611003202.dir/check_qt_visibility.cpp.o] Error 1
gmake: *** [cmTryCompileExec3611003202/fast] Error 2
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1297 (message):
  Qt compiled without support for -fvisibility=hidden.  This will break
  plugins and linking of some applications.  Please fix your Qt installation
  (try passing --reduce-exports to configure).
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  CMakeLists.txt:32 (FIND_PACKAGE)
RPM build errors:
Comment 1 Jens Petersen 2012-09-20 22:39:00 EDT
This also breaks ghc compilation in rawhide:

http://koji.fedoraproject.org/koji/getfile?taskID=4509451&name=build.log&offset=-4000
Comment 2 Jens Petersen 2012-09-20 22:44:56 EDT
Happens on both i686 and x86_64 fwiw, if it helps.
Comment 3 Jens Petersen 2012-09-20 22:46:59 EDT
Also (sorry for multiple comments) I don't think it happens with
glibc-2.16.90-11.fc19.
Comment 4 Siddhesh Poyarekar 2012-09-21 00:37:25 EDT
Looks like it has accidentally been caused by the patch to bug 858274. I've pushed the fix to rawhide. Please test glibc-2.16.90-13.fc19 once it is done:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4510418
Comment 5 Siddhesh Poyarekar 2012-09-21 01:03:24 EDT
Looks like it's not going to be that simple, since the glibc build itself is failing.  I can't simply untag glibc-2.16.90-13.fc19 since it is already published.
Comment 6 Kevin Kofler 2012-09-21 01:36:22 EDT
You can (and you mean -12, not -13), in fact I just did it for you.

As long as you build a fixed build with a higher EVR (e.g. the 2.16.90-13.fc19 you were going to use, no need to touch Epoch) ASAP, it's fine.
Comment 7 Kevin Kofler 2012-09-21 01:41:19 EDT
Now we need to wait for:
koji wait-repo f19-build --build glibc-2.16.90-11.fc19
to report that the buildroot has been regenerated, then we can resubmit the -13 build (and other builds will already succeed once -11 is back, but we need -13 for the upgrade paths of Rawhide users).
Comment 8 Kevin Kofler 2012-09-21 01:50:06 EDT
Successfully waited 5:14 for glibc-2.16.90-11.fc19 to appear in the f19-build repo

I'm resubmitting your build of glibc-2.16.90-13.fc19 now (using koji build rawhide git://pkgs.fedoraproject.org/glibc?#7e2e80de953ce07ebb3465830713ee5dfa134e56 because koji resubmit doesn't work on builds by somebody else). If it succeeds, we should be all set.
Comment 10 Siddhesh Poyarekar 2012-09-21 01:53:52 EDT
Thanks Kevin!  I resubmitted a build too, which I have cancelled now.:

https://koji.fedoraproject.org/koji/taskinfo?taskID=4510441
Comment 11 Siddhesh Poyarekar 2012-09-21 03:13:36 EDT
Build completed successfully in rawhide and byteswap-16.h is back. Things should start working again.
Comment 12 Kevin Kofler 2012-09-21 03:55:53 EDT
I resubmitted the libkipi build and it built successfully for Rawhide against glibc-2.16.90-13.fc19. Thanks for the quick fix!
Comment 13 Jens Petersen 2012-09-23 22:09:56 EDT
Thanks guys - rawhide ghc compilation also looks good again.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4518689

Note You need to log in before you can comment on or make changes to this bug.