Bug 859281 - RFE: rhn-channel to provide an option to query the existing base channel of the system.
RFE: rhn-channel to provide an option to query the existing base channel of t...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.5
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Milan Zazrivec
Pavel Studeník
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 21:52 EDT by jalviso
Modified: 2013-02-21 05:07 EST (History)
2 users (show)

See Also:
Fixed In Version: rhn-client-tools-1.0.0.1-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Customer request: ability to list base channel of a system Consequence: Fix: new -b option for rhn-channel utility which shows base channel of a system. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:07:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jalviso 2012-09-20 21:52:14 EDT
Description of problem: 
Request for Enhancement of "rhn-channel" command to include a switch to query the base channel of any RHEL system.

Version-Release number of selected component (if applicable):

How reproducible: 
It is reproducible.

Steps to Reproduce:
1. When invoking the command "rhn-channel", a switch to query the base channel 
   say "-b" would be ideal.
2. Currently, we can only get all channels available which includes base 
   channel in "rhn-channel -l" but the output doesn't show which line is the
   base channel.
3. Any other command that serves this purpose is acceptable but not the 
   Satellite API "Method: getSubscribedBaseChannel" because it is not plausible
   to the requesting customer's need.

Description:
Needs to provides the base channel of a given system through a command or additional switch for "rhn-channel" command.
  
Actual results:


Expected results:


Additional info: 

Please note that the rhn-client tools is selected in the Component field because there is no selection for rhn-setup.
Comment 2 Milan Zazrivec 2012-09-21 07:54:43 EDT
New '-b' option for rhn-channel / spacewalk-channel utility which lists
base channel that the system is subscribed to.

spacewalk.git master: 81df0f7ac4c1ac35f2311e897f75dbc6aa065acc
Comment 3 Milan Zazrivec 2012-09-21 07:58:22 EDT
Additional fix in spacewalk.git master: bbf617384638adf9babeb2018373f50dee0dbf6a
Comment 10 errata-xmlrpc 2013-02-21 05:07:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0388.html

Note You need to log in before you can comment on or make changes to this bug.