This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 859292 - It returns error message when creating scalable app via rhc client
It returns error message when creating scalable app via rhc client
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 22:48 EDT by Meng Bo
Modified: 2015-05-14 22:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-09-20 22:48:52 EDT
Description of problem:
Create scalable app via "rhc app create -a app1 -t php-5.3 -s" will get NoMethodError but the app is created successfully on instance.

Version-Release number of selected component (if applicable):
rhc-0.99.2
devenv_2207

How reproducible:
always

Steps to Reproduce:
1.Create scalable app via CLI
rhc app create -a app1 -t php-5.3 -s
  
Actual results:
Get error message like following but the app is created successfully

Submitting form:
debug: true
rhlogin: bmeng@redhat.com
Contacting https://
Creating application: php1s in bmengdev
/usr/lib/ruby/gems/1.8/gems/rhc-0.99.2/lib/rhc-common.rb:522:in `create_app': undefined method `uuid' for #<Hash:0xb69a1b20> (NoMethodError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.2/bin/rhc-app:229:in `create_app'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.2/bin/rhc-app:504
	from /usr/bin/rhc-app:19:in `load'
	from /usr/bin/rhc-app:19


Expected results:
App should be created successfully and return correct info from client side.

Additional info:
App can be created successfully on instance.
Comment 1 Xiaoli Tian 2012-09-21 23:43:59 EDT
Raise its severity and priority since it will block all automation testing.
Comment 2 John (J5) Palmieri 2012-09-24 21:44:23 EDT
This is fixed in my commands-merge branch. Will be rolling an ami tomorrow though other things may have broken.
Comment 3 John (J5) Palmieri 2012-09-27 16:44:49 EDT
Backported patch

master - https://github.com/openshift/rhc/pull/167

This issue only shows up in master so no hotfix needed for staging
Comment 4 Xiaoli Tian 2012-09-28 03:23:05 EDT
Verified it with the rhc built in 
fork_ami_US2597_US2599_US2813_US2817_US2872_173 against the latest devenv(devenv_2248) on Fedora17 with ruby-1,9 and git version 1.7.10.1.

Although there are still problem for other platforms, but it seems a different bug, will fill another bug to track.

[root@F17x64-openshift test]# rhc app create scaleruby1 ruby-1.9 -s -l xtian+t5@redhat.com 
Password: *

Creating application 'scaleruby1'
=================================

  Namespace: domx5
  Cartridge: ruby-1.9
  Gear Size: default
  Scaling:   yes

Your application's domain name is being propagated worldwide (this might take a minute)...
The authenticity of host 'scaleruby1-domx5.dev.rhcloud.com (50.17.163.18)' can't be established.
RSA key fingerprint is 71:92:68:7d:19:dc:2e:de:8f:e5:83:92:f9:1b:95:a5.
Are you sure you want to continue connecting (yes/no)? yes
Cloning into 'scaleruby1'...
done

RESULT:
Application scaleruby1 was created.

Note You need to log in before you can comment on or make changes to this bug.