Bug 859334 - update software (yum) breaks for ruby with request to report a bug
update software (yum) breaks for ruby with request to report a bug
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 03:49 EDT by Janusz
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 05:30:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Janusz 2012-09-21 03:49:59 EDT
Description of problem:
yum - ruby update does not work. updates stop with a message like:

ERROR with transaction check vs depsolve:
ruby-irb = 1.8.7.358-2.fc16 is needed by ruby-rdoc-1.8.7.358-2.fc16.noarch
rubygem-rake = 0.9.2.2-2.fc17 is needed by rubygem-rake-doc-0.9.2.2-2.fc17.noarch
Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum


Version-Release number of selected component (if applicable):
Fedora 17

How reproducible: reported on each software update since 2 weeks


Steps to Reproduce:
1. start update
 
Actual results:
update stops

Expected results:
update executed

Additional info:
Comment 1 Tim Lauridsen 2012-09-21 05:30:34 EDT
Not a yum problem, there is some old installed ruby packages there require some other ruby stuff, there is been updated to a new version and no longer fulfill the requirements of the old installed ruby package.
I simpler words the is no upgrade path for the installed ruby packages ruby-rdoc-1.8.7.358-2.fc16.noarch & rubygem-rake-doc-0.9.2.2-2.fc17.noarch.
maybe some ruby packages has not been rebuild or has not been pushed to the fedora  repositories yet.

1. wait a couple of days and try to see if it goes away.
2. remove the old ruby packages (ruby-rdoc-1.8.7.358-2.fc16.noarch & rubygem-rake-doc-0.9.2.2-2.fc17.noarch) if possible, they can be leftover from an older fedora release (.fc16)
3. If that don't work, make a bugzilla repport agaist the ruby-rdoc or rubygem-rake-doc package, there  can be problems with the packages.

Note You need to log in before you can comment on or make changes to this bug.