This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 859347 - It's impossible to switch user in KDE using LightDM
It's impossible to switch user in KDE using LightDM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
: Triaged
Depends On: 867924
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 05:14 EDT by Martin Bříza
Modified: 2012-12-20 11:01 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:01:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch to fix the issue (5.29 KB, patch)
2012-10-08 09:57 EDT, Martin Bříza
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 305632 None None None 2012-10-01 06:37:43 EDT

  None (edit)
Description Martin Bříza 2012-09-21 05:14:52 EDT
Description of problem:
Switching user using the KDE way is not possible when LightDM is used as login manager.

Version-Release number of selected component (if applicable):
lightdm-1.3.3-2.fc19.x86_64
lightdm-kde-0.3.0-1.fc19.x86_64
kde-workspace-4.8.5-3.fc17.x86_64 (with the fix for #849334)

How reproducible:
Always

Steps to Reproduce:
1. Kickoff -> Leave -> Switch User -> Continue
  
Actual results:
Screen flickers, returns to the current session

Expected results:
Creating a new session

Additional info:
The session was locked afterwards as I have locking set up on user switch.
Comment 1 Martin Bříza 2012-09-25 06:12:41 EDT
With kde-workspace-4.9.1-6.fc18.x86_64, the "Switch User" button is not present in the menu when LightDM is used. When KDM is used, the button is back though.
Comment 2 Martin Bříza 2012-09-27 06:54:21 EDT
So, as I found out, the button is missing because the environment asks the system (via SystemD or ConsoleKit) if the DM supports switching users.
LightDM may not present itself to the system as being capable of this feature but there is definitely a way of doing it - manually, using command "dm-tool switch-to-greeter", a new session is created, making it possible to log in for more users.
Comment 3 Christoph Wickert 2012-10-03 06:38:17 EDT
lightdm supports switching users. Just like gdm it comes with a gdmflexiserver binary which is exposed over dbus and can be called by dm-tool. Works fine here with lightdm-1.3.3-2 and lightdm-gtk-1.3.1-1, so the problem must either be in kdeworkspace or lightdm-kde.

I guess kdm does things differently and kdebase only supports kdm's way.
Comment 4 Martin Bříza 2012-10-03 07:18:27 EDT
Yes, I'm investigating this and it seems it's in our patch for systemd support in kde-workspace but I'm not 100% sure, testing it right now.
Comment 5 Martin Bříza 2012-10-08 09:57:58 EDT
Created attachment 623460 [details]
Proposed patch to fix the issue

QDBus refuses to return any of the types returned by SystemD as they are not registered according to its error messages. This patch works around this issue and makes it possible to correctly switch users in KDE using LightDM.
Comment 6 Kevin Kofler 2012-10-08 11:26:53 EDT
FWIW, this looks like a QDBus (or even QMetaObject) bug.
Comment 7 Martin Bříza 2012-10-08 11:33:00 EDT
Yes, it seems so. But what's strange - I looked this up on the Qt bugtracker and there was no report regarding this.... But to me it seems like something that should affect many more projects than just us.

And to this bugreport - there are still some issues left - from what I have found out, logging out still works really strange. After creating two sessions and logging from both of them, KDE reports (in a new session) that there are these two open (and lists them as "other" sessions, regardless the fact one of them is on the same VT as the present one).
Comment 8 Martin Bříza 2012-10-15 06:18:24 EDT
Also reported here: https://bugs.launchpad.net/lightdm/+bug/851612
Comment 9 Martin Bříza 2012-10-18 11:13:50 EDT
I found out today these issues belong under LightDM, reporting a new bug 867924 .
Regarding this issue, there is only one more minor problem I know of: the "Switch User" dialog lists sessions that are marked as closing.
Also removing the Launchpad tracker as I think the problem is in systemd support. I'll see when I fix it.
Comment 10 Kevin Kofler 2012-10-18 12:24:44 EDT
Martin, why did you invert the dependency order of the bugs? I think this one really depends on bug #867924 rather than blocking it.
Comment 11 Martin Bříza 2012-10-22 05:28:38 EDT
Sorry, Kevin, I did that by accident. Fixed now.
Comment 12 Fedora Update System 2012-10-23 08:38:50 EDT
kde-workspace-4.9.2-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kde-workspace-4.9.2-6.fc18
Comment 13 Fedora Update System 2012-10-23 15:45:18 EDT
Package kde-workspace-4.9.2-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-workspace-4.9.2-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16735/kde-workspace-4.9.2-6.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-10-30 16:11:34 EDT
Package kde-workspace-4.9.2-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-workspace-4.9.2-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16735/kde-workspace-4.9.2-7.fc18
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-12-20 11:01:28 EST
kde-workspace-4.9.2-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.