Bug 859360 - WARNING: at drivers/pci/msi.c:968 pci_enable_msi()
WARNING: at drivers/pci/msi.c:968 pci_enable_msi()
Status: CLOSED DUPLICATE of bug 851943
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 06:03 EDT by Qian Guo
Modified: 2012-09-21 07:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 07:11:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Guo 2012-09-21 06:03:59 EDT
Description of problem:
Try to boot a guest with pf/vf already used by another booted guest , kernel report:

kernel: Uhhuh. NMI received for unknown reason 30.
kernel: Do you have a strange power saving mode enabled?
kernel: Dazed and confused, but trying to continue

Kill this guest, every time boot a new guest with this pf/vf assigned, got:

warning: at drivers/pci/msi.c:968 pci_enable_msi()
kernel: Call Trace:
kernel:  [<ffffffff80171d7e>] pci_enable_msi+0x7e/0x315
kernel:  [<ffffffff8831f842>] :kvm:kvm_free_irq+0x24/0x40
kernel:  [<ffffffff8830910f>] :kvm:kvm_vm_ioctl+0x75e/0xc39
kernel:  [<ffffffff8830c066>] :kvm:emulator_write_emulated_onepage+0xac/0xf9
kernel:  [<ffffffff8831a333>] :kvm:x86_emulate_insn+0x3c05/0x4c89
kernel:  [<ffffffff8007a7a0>] ack_edge_ioapic_vector+0x40/0x42
kernel:  [<ffffffff8831bccb>] :kvm:x86_decode_insn+0x914/0xb19
kernel:  [<ffffffff8006ed34>] do_gettimeofday+0x40/0x90
kernel:  [<ffffffff8830721e>] :kvm:kvm_io_bus_find_dev+0x35/0x52
kernel:  [<ffffffff8022ebba>] pci_conf1_read+0xcc/0xd7
kernel:  [<ffffffff8016009e>] pci_user_read_config_byte+0x51/0x6d
kernel:  [<ffffffff80042482>] do_ioctl+0x21/0x6b
kernel:  [<ffffffff800304ca>] vfs_ioctl+0x457/0x4b9
kernel:  [<ffffffff800bad7a>] audit_syscall_entry+0x1a8/0x1d3
kernel:  [<ffffffff8004c884>] sys_ioctl+0x59/0x78
kernel:  [<ffffffff8005d29e>] tracesys+0xd5/0xdf


Version-Release number of selected component (if applicable):
host:
kernel-2.6.18-339.el5
kvm-83-262.el5
guest:
kernel-2.6.18-339.el5

How reproducible:
always

Steps to Reproduce:
1.modprobe -r ixgbe; modprobe ixgbe max_vfs=7, unbind 1 pf and 1 vf;
2.boot a guest with the pf/vf;
3.try to boot another guest with the same pf/vf, then the task failed
cli:
# /usr/libexec/qemu-kvm -m 3072 -smp 4   -startdate now -name mig -k en-us  -drive file=/mnt/nfs/rhel590910r2.qcow2,if=ide,format=qcow2,werror=stop,boot=on,media=disk -spice ic=on,disable-ticketing,port=9010 -qxl 1 -M rhel5.6.0 -balloon none -monitor stdio -pcidevice host=06:00.0

failure:
Failed to assign device "06:00.0" : Device or resource busy
Failed to deassign device "06:00.0" : Invalid argument
Failed to initialize assigned device host=06:00.0

4. quit all the qemu processes, then boot a guest with the same pf/vf
  
Actual results:
for step 3,
after the failure, the host's log:
kernel: Uhhuh. NMI received for unknown reason 30.
kernel: Do you have a strange power saving mode enabled?
kernel: Dazed and confused, but trying to continue
kernel: Uhhuh. NMI received for unknown reason 03.
kernel: Do you have a strange power saving mode enabled?
Sep 21 16:38:13 virtlab-66-84-72 kernel: Dazed and confused, but trying to continue

after step 4, the host had warning:
warning: at drivers/pci/msi.c:968 pci_enable_msi()
kernel: Call Trace:
kernel:  [<ffffffff80171d7e>] pci_enable_msi+0x7e/0x315
kernel:  [<ffffffff8831f842>] :kvm:kvm_free_irq+0x24/0x40
kernel:  [<ffffffff8830910f>] :kvm:kvm_vm_ioctl+0x75e/0xc39
kernel:  [<ffffffff8830c066>] :kvm:emulator_write_emulated_onepage+0xac/0xf9
kernel:  [<ffffffff8831a333>] :kvm:x86_emulate_insn+0x3c05/0x4c89
kernel:  [<ffffffff8007a7a0>] ack_edge_ioapic_vector+0x40/0x42
kernel:  [<ffffffff8831bccb>] :kvm:x86_decode_insn+0x914/0xb19
kernel:  [<ffffffff8006ed34>] do_gettimeofday+0x40/0x90
kernel:  [<ffffffff8830721e>] :kvm:kvm_io_bus_find_dev+0x35/0x52
kernel:  [<ffffffff8022ebba>] pci_conf1_read+0xcc/0xd7
kernel:  [<ffffffff8016009e>] pci_user_read_config_byte+0x51/0x6d
kernel:  [<ffffffff80042482>] do_ioctl+0x21/0x6b
kernel:  [<ffffffff800304ca>] vfs_ioctl+0x457/0x4b9
kernel:  [<ffffffff800bad7a>] audit_syscall_entry+0x1a8/0x1d3
kernel:  [<ffffffff8004c884>] sys_ioctl+0x59/0x78
kernel:  [<ffffffff8005d29e>] tracesys+0xd5/0xdf

Expected results:
"Uhhuh. NMI received for unknown reason 30" should not happen;
and no such warning

Additional info:
Comment 1 Amit Shah 2012-09-21 07:11:07 EDT

*** This bug has been marked as a duplicate of bug 851943 ***

Note You need to log in before you can comment on or make changes to this bug.