Bug 859363 - io-threads specific information is not dumped in statedump
io-threads specific information is not dumped in statedump
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Raghavendra Bhat
SATHEESARAN
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 06:22 EDT by SATHEESARAN
Modified: 2013-09-23 18:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 843377
Environment:
Last Closed: 2013-09-23 18:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2012-09-21 06:22:22 EDT
+++ This bug was initially created as a clone of Bug #843377 +++

Description of problem:
When statedump of a volume is taken, io-threads translator specific information is not dumped in the statedump file of the brick processes.

Version-Release number of selected component (if applicable):
RHS 2.0 update 2

How reproducible:


Steps to Reproduce:
1. get the statedump of the brick process ( kill -USR1 <brick-process-id>)
2. look for io-thread related info in the statedump (statedumps available in /tmp directory)

  
Actual results:
io-threads related information is missing

Expected results:
io-threads related information should be present in statedump

Additional info:

This bug is already rised over glusterfs 3.3.0  with Bug id - 843377
Comment 2 Amar Tumballi 2012-10-18 01:56:06 EDT
already fixed upstream, will be present in RHS-2.1. http://review.gluster.com/3736
Comment 3 SATHEESARAN 2013-07-24 05:02:22 EDT
statedump taken at server side (RHS side) has io-threads related information.
(i.e) gluster volume statedump <vol-name> generates statedump file @ /var/run/gluster/<statedump-file>, and it contains io-threads related information.

VERIFIED with glusterfs 3.4.0.12rhs.beta5-2
Comment 4 Scott Haines 2013-09-23 18:29:55 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.