Bug 859373 - Danger in dual booting Windows 8 and Linux
Danger in dual booting Windows 8 and Linux
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, ReleaseNotes, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 06:57 EDT by Jean-Pierre André
Modified: 2012-12-20 11:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:02:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-Pierre André 2012-09-21 06:57:29 EDT
Description of problem:

When using the "fast restart" feature, Windows 8 uses cached metadata saved at previous shutdown instead of what is actually on disk. This may occur on any partition of internal disks mounted by Windows (not limited to the Windows system partition).

Version-Release number of selected component (if applicable):

All versions

How reproducible:

Nearly always.

Steps to Reproduce:
1. Work on Windows 8, then shutdown with fast restart enabled.
2. Boot into Linux through grub.
3. Create some new files on an internal partition which was mounted by Windows, and leave Linux
4. Reboot into Windows 8 and check the files created by Linux
  
Actual results:

The files created by Linux may be missing, and new files created on Windows may overwrite them.
  
Expected results:

The files created by Linux should be visible.

Additional info:

This apparently only happens when :
a) the fast restart feature of Windows 8 is enabled
b) Windows 8 is closed using the "Shut down" button (it does not happen when using the "Restart" button)
c) the dual booting into Linux is done though grub (it does not happen when booting into Linux through the Windows multiboot feature).

Starting chkdsk when entering Windows 8 drops the cached metadata and restores the state left by Linux.

The only known work around is to disable the fast restart feature (see http://jp-andre.pagesperso-orange.fr/advanced-ntfs-3g.html#windows8 )
Comment 1 Tom "spot" Callaway 2012-09-21 12:45:10 EDT
Jean-Pierre, since the only known workaround is to disable the fast restart feature from within Windows 8, what do you want me to do here? We can document this in our release notes, but if you can't fix it... :)
Comment 2 Jean-Pierre André 2012-09-24 04:25:36 EDT
Well, Tom, this was intended to have to issue documented in a place where users might look at, rather than asking you to do some special thing. I will take care of having it documented in the manual.
Comment 3 Tom "spot" Callaway 2012-09-24 10:09:56 EDT
Okay, thanks. :) I wasn't sure what you were asking for me to do here.
Comment 4 Ben Cotton 2012-09-26 22:38:36 EDT
This has been referenced in the Fedora 18 release notes and in the Common Bugs page (https://fedoraproject.org/wiki/Common_F18_bugs#win8-fast-restart). Marking this bug closed.
Comment 5 Kamil Páral 2012-10-01 06:23:39 EDT
I believe CANTFIX resolution is more appropriate, it says that even though we documented the issue, it still persists and we can't really do much about it. (Otherwise someone could see just the "closed fixed" status and assume this has been fixed somehow). Changing resolution and also component back to ntfs-3g.

However, I believe there could be ways to improve the situation. We could detect whether Win 8 is present on the computer, and if we mount NTFS partition in such case, we could force chkdsk to be run on the next Windows boot. That would make sure user data are not lost. The question is whether we can do this only if fast-restart feature is turned on (whether we can detect that somehow), otherwise this solution could be a bit annoying.

Another solution is that the installer could try to disable fast-restart feature if it detects Win 8 (again, if this is possible at all).

These are wild guesses, I'm not the expert here.
Comment 6 Jean-Pierre André 2012-10-01 07:11:38 EDT
CANTFIX if probably appropriate to mean that mounting a file system not sync'ed by Windows cannot be prevented from being dangerous (hibernation and fast restart on Windows 8 imply not sync'ed to disk).

Now, I think it is possible to detect the dangerous situations and refuse to mount with *future* ntfs-3g versions. This might still be unpleasant to users. You may apply the following couple of patches for that :

first : http://ntfs-3g.git.sourceforge.net/git/gitweb.cgi?p=ntfs-3g/ntfs-3g;a=commit;h=4d0b9163c9ef1f0cdbbf533317b291220c7fd1c7

then : http://ntfs-3g.git.sourceforge.net/git/gitweb.cgi?p=ntfs-3g/ntfs-3g;a=commit;h=559270a8f67c77a7ce51246c23d2b2837bcff0c9

I have tested these patches, and they are scheduled for next ntfs-3g release.
Comment 7 Kamil Páral 2012-10-01 12:41:18 EDT
Jean-Pierre, that is great news. Refusing to mount is another great option how to make sure user data is safe. Ideally the high-level applications (Nautilus etc) could even display some reasonable error message.

Reopening this bug to track the progress.
Comment 8 Fedora Update System 2012-10-04 16:35:38 EDT
ntfs-3g-2012.1.15-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ntfs-3g-2012.1.15-4.fc17
Comment 9 Fedora Update System 2012-10-04 16:35:51 EDT
ntfs-3g-2012.1.15-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ntfs-3g-2012.1.15-4.fc18
Comment 10 Fedora Update System 2012-10-05 01:38:29 EDT
Package ntfs-3g-2012.1.15-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ntfs-3g-2012.1.15-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15452/ntfs-3g-2012.1.15-4.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-10-15 20:53:25 EDT
ntfs-3g-2012.1.15-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ntfs-3g-2012.1.15-5.fc17
Comment 12 Fedora Update System 2012-10-15 20:53:41 EDT
ntfs-3g-2012.1.15-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ntfs-3g-2012.1.15-5.fc18
Comment 13 Fedora Update System 2012-12-20 11:02:22 EST
ntfs-3g-2012.1.15-4.fc17 has been pushed to the Fedora 17 obsolete repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.