Bug 859393 - squid does not start after a clean install (if /var/spool/squid is empty)
squid does not start after a clean install (if /var/spool/squid is empty)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 08:35 EDT by Marcos Mello
Modified: 2012-12-01 03:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 06:33:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcos Mello 2012-09-21 08:35:01 EDT
Using squid-3.2.0.16-1.fc17.x86_64

Bug 747103 implemented cache_swap.sh to pre-create squid cache dirs before the actual daemon start. It worked for a while, but somewhere between F16 and F17 systemd started blocking forking processes in ExecStartPre, which broke the script, since for some reason squid even with "-z" forks itself by default.

One possible solution is to pass "-N" option to squid in cache_swap.sh. It will not fork and systemd will allow it to do its work.
Comment 1 Fedora Update System 2012-10-26 11:15:26 EDT
squid-3.2.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc18
Comment 2 Fedora Update System 2012-10-26 15:42:11 EDT
Package squid-3.2.3-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing squid-3.2.3-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16962/squid-3.2.3-2.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-11-20 08:18:22 EST
squid-3.2.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc17
Comment 4 Fedora Update System 2012-11-20 10:28:33 EST
squid-3.2.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc16
Comment 5 Fedora Update System 2012-12-01 03:31:16 EST
squid-3.2.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-12-01 03:42:41 EST
squid-3.2.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.