Bug 859434 - Set gpgcheck to 1 if a new gpgkey is updated and set
Set gpgcheck to 1 if a new gpgkey is updated and set
Status: CLOSED DUPLICATE of bug 834125
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-09-21 10:29 EDT by David Davis
Modified: 2013-02-22 15:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-22 15:44:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Davis 2012-09-21 10:29:46 EDT
Description of problem:

In katello, if I add a gpgkey to an existing subscription, then it gpgcheck remains 0. It would be nice if instead the gpgcheck got switched to 1.


Version-Release number of selected component (if applicable):

subscription-manager-0.99.19-1.el6.x86_64


How reproducible:

On a scale from 1-10, like 8 or 9.


Steps to Reproduce:

I'm not sure how to do this outside of katello :(

1. Create a org, environemnt, and product with repos in katello. Do not add a gpg key.
2. Create a client, add it to the env, and subscribe it to the product.
3. Go onto the client and install the cp rpm. Then run "subscription-manager refresh && yum repolist"
4. View the redhat.repo file in /etc/yum.repos.d/ and verify that gpgkey is not set and gpgcheck is 0.
5. In katello, add a gpg key to the product.
6. On the client, run "subscription-manager refresh && yum repolist".
  

Actual results:

The gpgkey is set in redhat.repo but gpgcheck is still 0.


Desired results:

The gpgkey is set in redhat.repo but gpgcheck is 1.
Additional info:
Comment 2 RHEL Product and Program Management 2012-12-14 03:47:05 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Bryan Kearney 2013-02-22 15:44:56 EST

*** This bug has been marked as a duplicate of bug 834125 ***

Note You need to log in before you can comment on or make changes to this bug.