Bug 859470 - add comments to /etc/katello/katello.yml to help users setup LDAP
add comments to /etc/katello/katello.yml to help users setup LDAP
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Jordan OMara
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 11:55 EDT by Aaron Weitekamp
Modified: 2014-11-09 17:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Weitekamp 2012-09-21 11:55:07 EDT
Description of problem:
Product documentation[1] explains how to edit /etc/katello/katello.yml for LDAP support but there are no comments in the file to assist users with LDAP config.

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/CloudForms/1.1/html/Installation_Guide/Configuring_LDAP_for_CloudForms_System_Engine.html

Version-Release number of selected component (if applicable):
1.1

How reproducible:
100%

Steps to Reproduce:
1. Open /etc/katello/katello.yml
2. observer no comments explaining supported values for 'warden' and 'ldap_roles'


Expected results:
common:
  # supported values: 'database' (local users) or 'ldap'
  warden:  ldap
  # allows locally-managed groups
  ldap_roles: true



Additional info: CloudEngine settings.yml file
:default_deltacloud_url: http://localhost:3002/api

:auth:
  # supported strategies: database, ldap
  :strategy: ldap
:groups:
  # allows locally-managed groups
  :enable_local: true
  # allows ldap-managed groups
  :enable_ldap: true
:iwhd:
  :url: http://localhost:9090
  :oauth:
    :consumer_key: wGj/SifuR8RWpwWPs+mrqL538C5mPwal
    :consumer_secret: dK+pzhdtnDYN3+7RBjlbp8PuT4PpaFAh
 
:imagefactory:
  :url: https://localhost:8075/imagefactory
  :oauth:
    :consumer_key: mlJTwxqbRmGM2VtptJr4QHqPBgasu7JV
    :consumer_secret: 52/fjbkRxwyYHl7t4eq11eojTZvLXah+

:session:
  :timeout: 15 # minutes
Comment 3 Mike McCune 2013-08-16 14:09:54 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 4 Mike McCune 2014-03-18 13:37:28 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.