Bug 859474 - When using g_network_address_address_enumerator_next(), ipv6 scope id is lost
When using g_network_address_address_enumerator_next(), ipv6 scope id is lost
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glib2 (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: beta
: ---
Assigned To: Colin Walters
Desktop QE
:
Depends On:
Blocks: 827115
  Show dependency treegraph
 
Reported: 2012-09-21 11:57 EDT by David Jaša
Modified: 2017-12-06 06:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:43:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-09-21 11:57:18 EDT
Description of problem:
When using g_network_address_address_enumerator_next(), ipv6 scope id is lost

This is a downstream version of https://bugzilla.gnome.org/show_bug.cgi?id=684404 . Reproducer is available as an attachment of upstream bug.

Version-Release number of selected component (if applicable):
glib2-2.22.5-7.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2012-09-21 12:03:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 Christophe Fergeau 2012-09-21 12:53:14 EDT
Situation is a bit different from upstream with glib 2.22 as it has no ipv6 scope id support (unless we patched that in). scope id support was added upstream in http://git.gnome.org/browse/glib/commit/?id=bf7408c30bac5b0a20202be5aaa850dd0ca1e671 which was first released with glib 2.31.10
Comment 4 RHEL Product and Program Management 2013-10-14 00:46:13 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 Jan Kurik 2017-12-06 06:43:42 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.