Bug 85951 - link gives error on bind mount
link gives error on bind mount
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-11 08:54 EST by Neal D. Becker
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Neal D. Becker 2003-03-11 08:54:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
link("/home/nbecker/RPM/RPMS/i386/boost-jam-3.1.3-1.i386.rpm", "/var/ftp/pub/rh8.0/boost-jam-3.1.3-1.i386.rpm") = -1 EXDEV (Invalid cross-device link)

/disk1/nbecker on /home/nbecker type none (rw,bind)

It isn't a cross device link.  /home/nbecker is a bind mount.  /disk1/nbecker and /var/ftp are on the same device.

Linking /disk1/nbecker to /var/ftp works OK.

The semantics of a link on a bind mount should be the same as if there was no bind mount.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ln
2.
3.
    

Additional info:
Comment 1 Bugzilla owner 2004-09-30 11:40:38 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.