Bug 859540 - Network Configuration page shows "None None" under network ports
Network Configuration page shows "None None" under network ports
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Betappc 872197
  Show dependency treegraph
 
Reported: 2012-09-21 15:25 EDT by Mark Hamzy
Modified: 2012-11-22 21:34 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 872197 (view as bug list)
Environment:
Last Closed: 2012-11-22 21:34:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Network Configuration screenshot (91.96 KB, image/png)
2012-09-21 15:25 EDT, Mark Hamzy
no flags Details
syslog (39.36 KB, application/octet-stream)
2012-10-03 18:31 EDT, Mark Hamzy
no flags Details
anaconda.log (2.05 KB, application/octet-stream)
2012-10-03 18:31 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2012-09-21 15:25:48 EDT
Created attachment 615582 [details]
Network Configuration screenshot

Description of problem:
The text under the network ports in the list box shows "None None".

See attached screenshot.

Version-Release number of selected component (if applicable):
anaconda 18.6.7

How reproducible:
Always

Steps to Reproduce:
1. Boot powerpc 64
2. Bring up Network Configuration page
Comment 1 Radek Vykydal 2012-09-24 10:11:09 EDT
Seems like NM's get_vendor and get_product methods are returning None in this specific HW case?

Are you able to attach some logs (messages seen on tty1, /tmp/syslog, /tmp/anaconda.log)?

We should at least present something more meaningful than "None" in such cases.
Comment 2 Mark Hamzy 2012-10-03 18:30:30 EDT
I reran with http://ppc.koji.fedoraproject.org/stage/f18-20121003-Beta-TC1.0/ppc64/iso/Fedora-18-Beta-ppc64-DVD.iso and the problem still occurs.

Remember, this is a ppc machine, so tty1 does not exist.
Comment 3 Mark Hamzy 2012-10-03 18:31:11 EDT
Created attachment 621189 [details]
syslog
Comment 4 Mark Hamzy 2012-10-03 18:31:42 EDT
Created attachment 621190 [details]
anaconda.log
Comment 5 Mark Hamzy 2012-10-03 18:37:27 EDT
[anaconda root@sharpie /]# cat << __EOF__ | python -
#!/usr/bin/python
from gi.repository import NMClient

if __name__ == "__main__":
        client = NMClient.Client.new()

        for con in client.get_active_connections():
                print con
                device = con.get_devices()[0]
                print device
                print device.get_vendor()
                print device.get_product()
__EOF__
<ActiveConnection object at 0x1002fad5960 (NMActiveConnection at 0x1002fb9f140)>
<DeviceEthernet object at 0x1002fad5a00 (NMDeviceEthernet at 0x1002fba6150)>
None
None
<ActiveConnection object at 0x1002fad59b0 (NMActiveConnection at 0x1002fb9f070)>
<DeviceEthernet object at 0x1002fad5a50 (NMDeviceEthernet at 0x1002fba6000)>
None
None
Comment 6 Radek Vykydal 2012-10-12 08:21:10 EDT
I pushed a patch that replaces None None with empty string, so from anaconda side this BZ should be fixed. If you want to pass it to NM or kernel for fix getting the actual info feel free to do so by changing the component.
Comment 7 Dan Williams 2012-10-16 11:54:50 EDT
Can I get 'udevadm info --attribute-walk --path=/sys/class/net/eth0' on either a running system or the install image?
Comment 8 Dan Williams 2012-10-16 11:58:24 EDT
Also 'udevadm info --query=property  --path=/sys/class/net/eth0'
Comment 9 Mark Hamzy 2012-10-16 12:06:53 EDT
[root@nibbler ~]# udevadm info --attribute-walk --path=/sys/class/net/eth0

Udevadm info starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

  looking at device '/devices/vio/30000003/net/eth0':
    KERNEL=="eth0"
    SUBSYSTEM=="net"
    DRIVER==""
    ATTR{mtu}=="1500"
    ATTR{type}=="1"
    ATTR{netdev_group}=="0"
    ATTR{flags}=="0x1003"
    ATTR{speed}=="1000"
    ATTR{dormant}=="0"
    ATTR{addr_assign_type}=="0"
    ATTR{dev_id}=="0x0"
    ATTR{duplex}=="full"
    ATTR{iflink}=="2"
    ATTR{addr_len}=="6"
    ATTR{address}=="2a:0f:41:b7:3f:03"
    ATTR{operstate}=="unknown"
    ATTR{broadcast}=="ff:ff:ff:ff:ff:ff"
    ATTR{tx_queue_len}=="1000"
    ATTR{ifalias}==""
    ATTR{ifindex}=="2"
    ATTR{link_mode}=="0"
    ATTR{carrier}=="1"

  looking at parent device '/devices/vio/30000003':
    KERNELS=="30000003"
    SUBSYSTEMS=="vio"
    DRIVERS=="ibmveth"
    ATTRS{name}=="l-lan"

  looking at parent device '/devices/vio':
    KERNELS=="vio"
    SUBSYSTEMS=="vio"
    DRIVERS==""
    ATTRS{name}=="vio"
    ATTRS{devspec}=="<no-node>"
[root@nibbler ~]# udevadm info --query=property  --path=/sys/class/net/eth0
DEVPATH=/devices/vio/30000003/net/eth0
ID_MM_CANDIDATE=1
IFINDEX=2
INTERFACE=eth0
INTERFACE_NAME=eth0
SUBSYSTEM=net
SYSTEMD_ALIAS=/sys/subsystem/net/devices/eth0
TAGS=:systemd:
USEC_INITIALIZED=824509
Comment 10 Dan Williams 2012-10-16 12:15:03 EDT
Two problems here:

1) Anaconda printing "None" because libnm-glib returned NULL for the description; returning NULL is legal here because we can't get any description

2) There is no identifying information for the interfaces in udev; that's because there are no udev rules that add the ID_MODEL_ENC, ID_VENDOR_ENC, ID_MODEL_FROM_DATABASE, or ID_VENDOR_FROM_DATABASE udev database keys.  If we add some udev rules that pull that information from somewhere and stuff it into those keys, then NM will pick them up.
Comment 11 Dan Williams 2012-10-16 12:17:23 EDT
To verify things are working correctly:

$ udevadm info --query=property --path=/sys/class/net/eth0
DEVPATH=/devices/pci0000:00/0000:00:19.0/net/eth0
ID_BUS=pci
ID_MM_CANDIDATE=1
ID_MODEL_FROM_DATABASE=82567LM Gigabit Network Connection
ID_MODEL_ID=/sys/devices/pci0000:00/0000:00:19.0
ID_VENDOR_FROM_DATABASE=Intel Corporation
ID_VENDOR_ID=0x8086
IFINDEX=3
INTERFACE=eth0
INTERFACE_NAME=eth0
SUBSYSTEM=net
SYSTEMD_ALIAS=/sys/subsystem/net/devices/eth0
TAGS=:systemd:
USEC_INITIALIZED=5755360

If you see the ID_MODEL_FROM_DATABASE or ID_MODEL_ENC keys in this dump, then we expect NetworkManager to provide them via libnm-glib, which is what Anaconda uses to show them in the UI.  We would expect them to show in the UI as well.
Comment 12 Fedora Update System 2012-10-16 23:08:44 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 13 Fedora Update System 2012-10-17 13:30:23 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-10-17 22:37:43 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 15 Fedora Update System 2012-10-18 11:29:58 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-10-19 21:33:27 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 17 Adam Williamson 2012-11-22 21:34:09 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.