Bug 859546 - dmidecode AVC related to accessing ld.so.cache
dmidecode AVC related to accessing ld.so.cache
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 15:41 EDT by Hans de Goede
Modified: 2012-09-26 16:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 16:47:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2012-09-21 15:41:50 EDT
Hi,

I just noticed the following AVC in audit.log:

type=AVC msg=audit(1348256238.384:11): avc:  denied  { read } for  pid=733 comm="dmidecode" name="ld.so.cache" dev="sdb1" ino=917779 scontext=system_u:system_r:dmidecode_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:etc_t:s0 tclass=file
type=SYSCALL msg=audit(1348256238.384:11): arch=c000003e syscall=2 success=no exit=-13 a0=7f19102558e4 a1=80000 a2=1 a3=0 items=0 ppid=686 pid=733 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="dmidecode" exe="/usr/sbin/dmidecode" subj=system_u:system_r:dmidecode_t:s0-s0:c0.c1023 key=(null)

Harmless since ld.so will fallback to a non cache searc of /lib /usr/lib, but still something which ought to be fixed :)

Regards,

Hans
Comment 1 Daniel Walsh 2012-09-26 16:47:56 EDT
Hans. for some reason ld.so.cache is mislabeled.

restorecon /etc/ld.so.cache

There was a bad policy out for a while that could cause default labeling to get screwed up.

Make sure you update to -25 or later

selinux-policy-3.11.1-25

Note You need to log in before you can comment on or make changes to this bug.