Bug 859557 - Change Interval to Frequency in CLI (rhsmcertd --cert-interval & --heal-interval) to match rhsm.conf
Change Interval to Frequency in CLI (rhsmcertd --cert-interval & --heal-inter...
Status: CLOSED DUPLICATE of bug 882459
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-09-21 16:25 EDT by Matt Reid
Modified: 2013-02-19 15:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 15:07:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-09-21 16:25:07 EDT
Description of problem:
If you edit rhsm.conf, under [rhsmcertd] it lists:
# Frequency of certificate refresh (in minutes)
certFrequency = 240
# Frequency of autoheal check (1440 min = 1 day):
healFrequency = 1440

but if you try to alter these using rhsmcertd from the CLI, the commands you must use are different, instead of frequency, they are interval.

# rhsmcertd --heal-interval=240
# rhsmcertd --cert-interval=60

I think these should be consistent, right now if they try to move from temporarily modifying rhsmcertd using rhsmcertd in the CLI, to changing the conf file, the commands look different, even though its all the same stuff in the same tool (rhsmcertd).

It sounded like changing the -- commands used in the cli would be easier than updating the conf file, but however we can get these in line works for me.

Version-Release number of selected component (if applicable):
sub-man 1.0.17-1
Comment 2 William Poteat 2013-02-19 15:07:49 EST

*** This bug has been marked as a duplicate of bug 882459 ***

Note You need to log in before you can comment on or make changes to this bug.