Bug 859623 - Promotion of RHEL content fails with RequestTimeout but UI says promotion completed
Promotion of RHEL content fails with RequestTimeout but UI says promotion com...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 10:34 EDT by Og Maciel
Modified: 2014-01-27 09:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 19:51:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (52.04 KB, image/png)
2012-09-22 10:34 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-09-22 10:34:53 EDT
Created attachment 615827 [details]
Screenshot

Description of problem:

I'm not sure if this is a transient (though I've seen it twice already) since the process of syncing/promoting RHEL content worked fine before with this same code base, so I'm filing this bug to make sure everything is ok. The error I see is:

  Resources::Pulp::Repository: Request Timeout (GET /pulp/api/repositories/QE-DEV-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/packages/) (RestClient::RequestTimeout)

For what is worth, my system was acting pretty slow and syncing RHEL 6.2 Server x96_64 RPMs didn't get queued up right away in the web ui. I walked away from the system for several hours and when I came back the web ui displayed that the sync had completed. That's when I tried to promote the product and saw the error. Notice that the web ui says that the promotion was applied.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Upload a valid manifest file
2. Enable RHEL 6.2 Server x86_64 repos for CloudForms Tools and RPMs
3. Sync repositories
4. Promote product
  
Actual results:

Web ui displays both error message and states promotion was applied

Expected results:


Additional info:

Pulp log shows:

[DEBUG: 2012-09-22 09:53:33 #9081] Resource GET request: /pulp/api/repositories/QE-DEV-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server/errata/?
[DEBUG: 2012-09-22 09:53:40 #9081] Processing response: 200
[DEBUG: 2012-09-22 09:53:52 #9081] Task TaskStatus (6) error
Comment 4 Og Maciel 2012-09-22 11:23:21 EDT
I re-synced the product and re-promoted it with success. I wonder if there was something going on with CDN?
Comment 6 Og Maciel 2012-09-27 19:51:16 EDT
It was probably a network blip... has worked consistently now.
Comment 7 Mike McCune 2013-08-16 14:06:14 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.