Bug 859647 - "sudo su " gives error
"sudo su " gives error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 14:27 EDT by Steven Usdansky
Modified: 2013-09-30 09:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 09:06:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2012-09-22 14:27:59 EDT
Description of problem:
sudo su gives error rather than allowing me to become root

Version-Release number of selected component (if applicable):
sudo-1.8.6-1.fc18.x86_64

How reproducible:
100% of the time


Steps to Reproduce:
1. sudo su
  
Actual results:
bash: [: =: unary operator expected


Expected results:
root prompt in directory that was current when sudo was invoked

Additional info:
downgrading to sudo-1.8.5-4.fc18.x86_64 cleared up the problem
Comment 1 Daniel Kopeček 2013-09-30 09:06:44 EDT
Seems to be fixed in the current version.

[dkopecek@rhws ~]$ sudo su
[root@rhws dkopecek]# rpm -q sudo
sudo-1.8.6p7-1.fc18.x86_64

Note You need to log in before you can comment on or make changes to this bug.