Bug 859656 - [abrt] colord-0.1.23-1.fc17: __opendirat: Process /usr/libexec/colord-sane was killed by signal 11 (SIGSEGV)
[abrt] colord-0.1.23-1.fc17: __opendirat: Process /usr/libexec/colord-sane wa...
Status: CLOSED DUPLICATE of bug 858714
Product: Fedora
Classification: Fedora
Component: colord (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:ce05f32a59d763d46df4963f824...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 17:35 EDT by Steve Tyler
Modified: 2013-04-24 06:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-24 06:34:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.11 KB, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: environ (185 bytes, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: backtrace (26.57 KB, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: cgroup (168 bytes, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: maps (48.25 KB, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: dso_list (13.22 KB, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: var_log_messages (9.77 KB, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details
File: open_fds (360 bytes, text/plain)
2012-09-22 17:35 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-09-22 17:35:06 EDT
Description of problem:
This happens while rebooting.

Version-Release number of selected component:
colord-0.1.23-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/libexec/colord-sane
crash_function: __opendirat
kernel:         3.5.4-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 __opendirat at ../sysdeps/unix/opendir.c
: #1 __opendir at ../sysdeps/unix/opendir.c
: #2 usbfs_get_device_list at os/linux_usbfs.c
: #3 op_get_device_list at os/linux_usbfs.c
: #4 libusb_get_device_list at core.c
: #5 musb_probe_devices at io/hpmud/musb.c
: #6 hpmud_probe_devices at io/hpmud/hpmud.c
: #7 DevDiscovery at scan/sane/hpaio.c
: #8 sane_hpaio_get_devices at scan/sane/hpaio.c
: #9 sane_dll_get_devices at dll.c
Comment 1 Steve Tyler 2012-09-22 17:35:09 EDT
Created attachment 615914 [details]
File: core_backtrace
Comment 2 Steve Tyler 2012-09-22 17:35:10 EDT
Created attachment 615915 [details]
File: environ
Comment 3 Steve Tyler 2012-09-22 17:35:12 EDT
Created attachment 615916 [details]
File: limits
Comment 4 Steve Tyler 2012-09-22 17:35:13 EDT
Created attachment 615917 [details]
File: backtrace
Comment 5 Steve Tyler 2012-09-22 17:35:15 EDT
Created attachment 615918 [details]
File: cgroup
Comment 6 Steve Tyler 2012-09-22 17:35:16 EDT
Created attachment 615919 [details]
File: maps
Comment 7 Steve Tyler 2012-09-22 17:35:18 EDT
Created attachment 615920 [details]
File: dso_list
Comment 8 Steve Tyler 2012-09-22 17:35:20 EDT
Created attachment 615921 [details]
File: var_log_messages
Comment 9 Steve Tyler 2012-09-22 17:35:21 EDT
Created attachment 615922 [details]
File: open_fds
Comment 10 Steve Tyler 2012-09-22 17:42:41 EDT
This was in an F17 VM running on an F17 host.

$ qemu-kvm -m 1024 -hda f17-test-1.img

qemu-kvm-1.0.1-1.fc17.x86_64
Comment 11 Steve Tyler 2012-09-22 23:50:28 EDT
This happens while rebooting.
Running in a VM.


backtrace_rating: 4
Package: colord-0.1.22-2.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 12 Pedro Martins 2012-11-02 07:34:17 EDT
After updating, got this error. I had it previously but since I do not use a scanner (related to sane?) it didn't bother me; but seems to be recurring.

backtrace_rating: 4
Package: colord-0.1.23-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Matthew 2013-04-01 12:39:17 EDT
I just started the system and logged into it, then the bug just appeared.

This is Fedoara 17, 64 bit running as a virtual machine on ESXi 5.1

backtrace_rating: 4
cmdline:        /usr/libexec/colord-sane
crash_function: __opendirat
executable:     /usr/libexec/colord-sane
kernel:         3.7.3-101.fc17.x86_64
package:        colord-0.1.23-1.fc17
reason:         Process /usr/libexec/colord-sane was killed by signal 11 (SIGSEGV)
uid:            996
ureports_counter: 1
Comment 14 Richard Hughes 2013-04-24 06:34:20 EDT

*** This bug has been marked as a duplicate of bug 858714 ***

Note You need to log in before you can comment on or make changes to this bug.