Bug 859714 - Logitech Headset H800 doesnt work anymore since Linux 3.5
Logitech Headset H800 doesnt work anymore since Linux 3.5
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 09:10 EDT by tobias.rudert
Modified: 2015-11-10 13:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-23 05:02:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of alsa-info after trying to connect (50.82 KB, application/octet-stream)
2012-09-23 09:10 EDT, tobias.rudert
no flags Details

  None (edit)
Description tobias.rudert 2012-09-23 09:10:59 EDT
Created attachment 616105 [details]
output of alsa-info after trying to connect

Description of problem
Using the headset Logitech H800 doesnt work anymore since Linux 3.5.x on Fedora 17. The problem occures on 2 different machines running Linux 3.5.x and with KDE and Gnome (for configuration).

It did work with Linux <3.5.x on Fedora 17. It also works perfectly when connecting via bluetooth to a smartphone running Linux 3.2.x.

How reproducible:
Connecting the headset via cable or wireless and switching it on. The headset doesnt work, nether automatic via plug&play nor by trying a manual configuration.

Actual results:
When trying to use the headset, dmesg reports:
"
[410640.927670] usb 1-2.1: USB disconnect, device number 4
[410641.616018] usb 1-2.1: new full-speed USB device number 7 using ehci_hcd
[410642.006783] usb 1-2.1: New USB device found, idVendor=046d, idProduct=0a29
[410642.006800] usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[410642.006808] usb 1-2.1: Product: Logitech Wireless Headset
[410642.006814] usb 1-2.1: Manufacturer: Logitech
[410642.022877] ALSA sound/usb/stream.c:200 7:1:1 : no or invalid class specific endpoint descriptor
[410642.024106] ALSA sound/usb/stream.c:200 7:2:1 : no or invalid class specific endpoint descriptor
[410642.025341] ALSA sound/usb/mixer.c:866 2:0: cannot get min/max values for control 2 (id 2)
[410642.025353] ALSA sound/usb/mixer.c:866 5:0: cannot get min/max values for control 2 (id 5)
[410642.035523] input: Logitech Logitech Wireless Headset as /devices/pci0000:00/0000:00:12.2/usb1/1-2/1-2.1/1-2.1:1.3/input/input14
[410642.036378] hid-generic 0003:046D:0A29.0005: input,hiddev0,hidraw2: USB HID v1.11 Device [Logitech Logitech Wireless Headset] on usb-0000:00:12.2-2.1/input3
"

Output of alsa-info has been attached.

Expected results:
Having the headset just working after connecting and switching it on, or at least after selecting it as output device in the configuration.

Additional info:
The streaming logic of USB-audio has been rewritten and pulled into Linux 3.5:
http://thread.gmane.org/gmane.linux.kernel/1302133
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=8fdff6a319e7dac757c558bd283dc4577e68cde7

The pull request refers to itself for new problems with usb-audio.

Ubuntu got a bug about this hardware, but it seems to be related to xserver-xorg-input-evdev and Ubuntu 12.04 (Linux 3.2.x):
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/973297
Comment 1 tobias.rudert 2012-12-23 05:02:49 EST
Works on Linux 3.6.10-2.fc17.x86_64.
Comment 2 Timothy M. Butterworth 2015-11-10 13:05:47 EST
I am no longer able to get The H800 to pair with Fedora 23 Kernel 4.2.5! When placing the headset into pairing mode KDE detects the headset but then gives a pairing fails message.

Note You need to log in before you can comment on or make changes to this bug.