Bug 859725 - Wireless iwl3945 after kernel 2.6.32-220.23.1 broke
Wireless iwl3945 after kernel 2.6.32-220.23.1 broke
Status: CLOSED DUPLICATE of bug 827193
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Stanislaw Gruszka
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 10:56 EDT by Paulo Roma Cavalcanti
Modified: 2013-03-05 17:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 08:14:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant part of /var/log/messages (61.95 KB, text/plain)
2012-09-29 09:41 EDT, Paulo Roma Cavalcanti
no flags Details

  None (edit)
Description Paulo Roma Cavalcanti 2012-09-23 10:56:05 EDT
Description of problem:

If I use any kernel of the 2.6.32-279 series
my laptop (Dell Vostro 1400) freezes after sometime,
and a blue light starts to blink on the keyboard.
I have to shut down by holding the power button... 

My kernel is tainted because I use the proprietary nvidia
driver, but the culprit is the iwl3945 module. 

 
Version-Release number of selected component (if applicable):

Kernel 2.6.32-279.5.2.el6.x86_64 was my last unsuccessful attempt.

How reproducible:

Just boot in any recent rhel6 kernel and wait some time ...

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Kernel should work as before the 279 series.

Additional info:

Kernel 2.6.32-220.23.1.el6.x86_64 works just fine.
Comment 2 John W. Linville 2012-09-28 11:26:09 EDT
Perhaps you can tell us what makes you think that iwl3945 is the problem?
Comment 3 Paulo Roma Cavalcanti 2012-09-29 09:41:36 EDT
Created attachment 619049 [details]
Relevant part of /var/log/messages

kernel used 2.6.32-279.9.1.el6.x86_64
Comment 4 Paulo Roma Cavalcanti 2012-09-29 09:50:50 EDT
The network works for a few minutes
and then the connection is lost. 
If I leave the system running this way, it just freezes.

This has been happening since the first 279 kernel,
with either the stock RedHat kernel or Centos. I tried
everything I could. It only works with kernel-2.6.32-220.23.1
or below.

I run rhel6 on several other desktop/notebooks with
no problem at all, but this is the only notebook I have 
with this wireless hardware from Dell...
Comment 5 Stanislaw Gruszka 2012-10-03 08:14:31 EDT
This is memory leak which will be fixed on RHEL6.4 . If you need that fix in RHEL6.3 you have to contact official RH support.

*** This bug has been marked as a duplicate of bug 827193 ***
Comment 6 Cristian Gheorghe Florescu 2013-03-05 17:19:08 EST
There is any workaround until kernel upgrade ...???

I've the same issue on HP 6710b ...

P.S.
I almost proceed to change my hdd until I identified that is a bug.
SATA hdd freeze and kernel coud not manage current tasks in terms of IO.

Thank you

Note You need to log in before you can comment on or make changes to this bug.