Bug 859740 - php-getid3 ships an unsupported development version
php-getid3 ships an unsupported development version
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: php-getid3 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paulo Roma Cavalcanti
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 858841
  Show dependency treegraph
 
Reported: 2012-09-23 13:13 EDT by Gregor Tätzner
Modified: 2012-10-23 11:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 07:51:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gregor Tätzner 2012-09-23 13:13:37 EDT
Description of problem:
currently this package contains an unstable and unsupported release. According to upstream this is not meant for production use.

Version-Release number of selected component (if applicable):
php-getid3-2.0.0b5-4.fc17

Please downgrade to the latest stable release 1.9.3.

according to repoquery no package in fedora is using php-getid3. So there should be no compatibility issues.
Comment 1 Gregor Tätzner 2012-10-07 06:59:14 EDT
can you handle this situation until release of F-18?
Comment 2 Paulo Roma Cavalcanti 2012-10-07 08:19:14 EDT
The reason I used the devel version was because the package
I had in mind was ampache. However, I doubt ampache will ever be
part of Fedora...

I will prepare a downgraded version and leave it in testing for F18.
Comment 3 Paulo Roma Cavalcanti 2012-10-07 08:41:33 EDT
I have a scratch build here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4568362


Can you try it?
Comment 4 Gregor Tätzner 2012-10-07 11:39:48 EDT
thanks, working fine. Though I have some notes and a wish:

big issue:
this line pulls in apache, you can use php-common instead
Requires:  php >= 5.0.0

also you should/must require the php extensions explicitly:
https://fedoraproject.org/wiki/Packaging:PHP#Extensions_Requires

phpci print --recursive --report extension /usr/share/php/getid3/
70 / 70 [+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++>] 100.00%
BASE: /usr/share/php/getid3
-------------------------------------------------------------------------------
PHP COMPAT INFO EXTENSION SUMMARY
-------------------------------------------------------------------------------
  EXTENSION                                        PECL   VERSION         COUNT
-------------------------------------------------------------------------------
  Core                                         5.4.7-dev  4.0.0            1858
  SPL                                                0.2  5.0.0              29
  SimpleXML                                          0.1  5.0.0               1
  date                                                    4.0.0              13
  exif                                                    4.0.1               1
  gd                                                      4.0.0               1
  iconv                                                   4.0.5               1
  mysql                                              1.0  4.0.0              27
  pcre                                                    4.0.0              93
  standard                                     5.4.7-dev  4.0.0            4780
  xml                                                     4.0.0              13
  zlib                                               2.0  4.0.0               6
-------------------------------------------------------------------------------

But I think some of them are optional (at least php-mysql)

also the fsf-address is wrong:
php-getid3.noarch: E: incorrect-fsf-address /usr/share/doc/php-getid3-1.9.3/license.txt

and my wish:
Can you include this package also in epel/el6? You won't have to adjust it.
Comment 5 Paulo Roma Cavalcanti 2012-10-07 12:30:11 EDT
From the list of extensions, almost all of them are already
in php-common. The missing ones are php-gd and php-mysql.

However, php-mysql conflicts with php-mysqlnd on my system ...
Therefore, I will not include php-mysql.

Of course I can build pgp-getid3 for rhel6, but the fsf-address issue
should not be fixed by me. Its up-stream's business, I guess ...

If this is OK for you, I will use the version below:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4568721
Comment 6 Gregor Tätzner 2012-10-07 17:33:34 EDT
(In reply to comment #5)
> Of course I can build pgp-getid3 for rhel6, but the fsf-address issue
> should not be fixed by me. Its up-stream's business, I guess ...
to a part, the wiki states:
https://fedoraproject.org/wiki/Common_Rpmlint_issues#incorrect-fsf-address

so you are supposed to include an updated gpl2 license file, until upstream fixes this

apart from that, we are good to go :)
Comment 7 Fedora Update System 2012-10-07 18:54:23 EDT
php-getid3-1.9.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/php-getid3-1.9.3-1.fc18
Comment 8 Fedora Update System 2012-10-08 11:27:27 EDT
Package php-getid3-1.9.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-getid3-1.9.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15618/php-getid3-1.9.3-1.fc18
then log in and leave karma (feedback).
Comment 9 Gregor Tätzner 2012-10-12 01:51:52 EDT
Can you push the update to F-17 as well?
Comment 10 Fedora Update System 2012-10-12 07:43:32 EDT
php-getid3-1.9.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/php-getid3-1.9.3-1.fc17
Comment 11 Paulo Roma Cavalcanti 2012-10-12 07:51:15 EDT
I am closing this bug, because the package is in testing
for F17, F18 and rhel6.
Comment 12 Fedora Update System 2012-10-13 07:37:01 EDT
php-getid3-1.9.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/php-getid3-1.9.3-1.fc16

Note You need to log in before you can comment on or make changes to this bug.