Bug 859823 - D include dir
D include dir
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ldc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: MERCIER Jonathan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 02:36 EDT by MERCIER Jonathan
Modified: 2012-10-23 15:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 15:30:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MERCIER Jonathan 2012-09-24 02:36:10 EDT
Dear,

As now both gcc ad llvm as a D compiler /usr/include/d should anymore own by ldc but by filesystem as /usr/include.

kinds regards
Comment 1 Ondrej Vasik 2012-09-24 07:29:13 EDT
Hi Jonathan, could you please clarify the request?

Directory /usr/include is already created&owned by filesystem package. I don't think filesystem package should own /usr/include/d (even if it will result in owning /usr/include/d by both llvm and gcc). Is there any reason for owning this directory by filesystem package?
Comment 2 MERCIER Jonathan 2012-09-24 18:49:40 EDT
the reason it is :
 - both ldc / gdc take include  file from  /usr/include/d

If an user use only ldc and gdc own /usr/include/d they are an extra dependency

same in other way


If an user use only gdc and ldc own /usr/include/d they are an extra dependency

then it seem the better way that is to set file-system as owner, no ?
Comment 3 Fedora Update System 2012-09-26 05:41:41 EDT
ldc-2-29.20120921git8968103.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ldc-2-29.20120921git8968103.fc17
Comment 4 Fedora Update System 2012-09-27 00:17:22 EDT
Package ldc-2-29.20120921git8968103.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ldc-2-29.20120921git8968103.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14865/ldc-2-29.20120921git8968103.fc17
then log in and leave karma (feedback).
Comment 5 Ondrej Vasik 2012-09-27 11:06:57 EDT
If both packages own the directory, I don't see any reason for additional unnecessary dependency. You'll simply have one of the packages installed and that's just fine - if you'll have two of them, two of the packages will own the directory.
Note: There are already many directories under /usr/share which are owned by multiple packages. 

Reason for filesystem inclusion is usually:
1) Many common packages will need to own this directory (because they put/use files in it)
2) Directory needs to be on place even if the packages which should normally own it are not installed (e.g. common plugins place/initscripts directory)

Note You need to log in before you can comment on or make changes to this bug.