Bug 859830 - KVM: entry failed, hardware error 0x80000021
KVM: entry failed, hardware error 0x80000021
Status: CLOSED DUPLICATE of bug 854983
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 02:55 EDT by Jan ONDREJ
Modified: 2012-10-03 03:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 03:30:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2012-09-24 02:55:22 EDT
Description of problem:
Starting with kernel kernel-3.5.3-1.fc17.x86_64 I can't use qemu-kvm on my machines. After hang qemu-kvm process is stopped, unable to continue with booting. Reverting back to kernel 3.5.2 works for me as workaround.

Version-Release number of selected component (if applicable):
kernel-3.5.3-1.fc17.x86_64
kernel-3.5.4-1.fc17.x86_64

Latest working kernel:
kernel-3.5.2-3.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. qemu-kvm -m 1024
  
Actual results:
Error message in terminal:
KVM: entry failed, hardware error 0x80000021

If you're running a guest on an Intel machine without unrestricted mode
support, the failure can be most likely due to the guest entering an invalid
state for Intel VT. For example, the guest maybe running in big real mode
which is not supported on less recent Intel processors.

EAX=00000011 EBX=00000000 ECX=00000030 EDX=00007baa
ESI=c007df0a EDI=000385c8 EBP=00000000 ESP=00007baa
EIP=00000370 EFL=00010006 [-----P-] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0030 0009c6f0 ffffffff 0000f300 DPL=3 DS16 [-WA]
CS =9be0 0009be30 0000ffff 00009b00 DPL=0 CS16 [-RA]
SS =0000 00000000 0000ffff 00009300 DPL=0 DS16 [-WA]
DS =0030 0009c6f0 ffffffff 0000f300 DPL=3 DS16 [-WA]
FS =0030 0009c6f0 ffffffff 0000f300 DPL=3 DS16 [-WA]
GS =0030 0009c6f0 ffffffff 0000f300 DPL=3 DS16 [-WA]
LDT=0000 00000000 0000ffff 00008200 DPL=0 LDT
TR =0000 00000000 0000ffff 00008b00 DPL=0 TSS32-busy
GDT=     0009c730 00000037
IDT=     00000000 0000ffff
CR0=00000011 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
Code=66 0f 01 16 40 00 66 0f 01 1e 78 00 0f 20 c0 0c 01 0f 22 c0 <66> ea a4 00 00 00 08 00 0f 20 c0 24 fe 0f 22 c0 ff 2e 7e 00 2e a1 14 08 8e d8 8e c0 8e e0

KVM curses output in emulation:
SeaBIOS (version 1.7.0-20120528_224116-x86-16.phx2.fedoraproject.org)           
                                                                                
                                                                                
                                                                                
iPXE (http://ipxe.org) 00:03.0 C900 PCI2.10 PnP PMM+3FFC9CA0+3FF89CA0 C900      
                                                                                
                                                                                
Booting from Hard Disk...                                                       
Boot failed: could not read the boot disk                                       
                                                                                
Booting from DVD/CD...                                                          
Boot failed: Could not read from CDROM (code 0003)                              
Booting from ROM...                                                             
iPXE (PCI 00:03.0) starting execution...                                        


Expected results:
no error and continue of working qemu
Comment 1 Luc de Louw 2012-10-03 03:30:07 EDT

*** This bug has been marked as a duplicate of bug 854983 ***

Note You need to log in before you can comment on or make changes to this bug.