This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 859881 - yum upgrade selinux-policy-targeted runs restorecon
yum upgrade selinux-policy-targeted runs restorecon
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 05:34 EDT by Need Real Name
Modified: 2012-09-25 16:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 16:52:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2012-09-24 05:34:50 EDT
Description of problem:
When I run a yum upgrade, restorecon gets called.

This seems like a bad idea: what if an attacker can write a file to my home directory and it gets the wrong label? Then I run an upgrade, and the file is given a good label?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2012-09-25 16:52:50 EDT
As an attacker you should not have been allowed to write a bad label in the first place.  restorecon is only run on differences between previous policy and new policy, which would not effect the homedir.

If a confined app is able to write something to your homedir then most likely the better attack route is to modify an app, since we run users as unconfined_t we are not necessarily protecting the user.

Note You need to log in before you can comment on or make changes to this bug.