Bug 859901 - [fork] Can not embed rockmongo to ruby-1.9 app
[fork] Can not embed rockmongo to ruby-1.9 app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 07:17 EDT by Jianwei Hou
Modified: 2015-05-14 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
development.log (23.47 KB, text/x-log)
2012-09-24 07:17 EDT, Jianwei Hou
no flags Details

  None (edit)
Description Jianwei Hou 2012-09-24 07:17:19 EDT
Created attachment 616481 [details]
development.log

Description of problem:
caught node execution failure when embedding rockmongo-1.1 to a ruby-1.9 application

Version-Release number of selected component (if applicable):
On fork_ami_US2105_133

How reproducible:
Always

Steps to Reproduce:
1. Create a ruby-1.9 app and embed mongodb
2. Embed rockmongo-1.1 to this app 

  
Actual results:
hjw@my apps$ rhc app cartridge add -a ruby19 -c rockmongo-1.1 -d -pxxx
Contacting https://ec2-107-21-160-59.compute-1.amazonaws.com
Problem reported from server. Response code was 500.

DEBUG:
Failed to restart master httpd, please contact support
Cartridge return code: 120

Exit Code: 143
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
api_c: ["placeholder"]
API version:    1.1.3

RESULT:
Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.


Expected results:
Should embed rockmongo-1.1 successfully

Additional info:
Didn't reproduce for ruby-1.8 cartridge
Comment 1 Paul Morie 2012-09-25 15:33:44 EDT
The problem was a missing dependency for open4 for ruby-1.9.3. I've added the dep and pushed a fix for this.  I've added the dependency.
Comment 2 Xiaoli Tian 2012-09-27 01:47:20 EDT
Move it to ON_QA to verify in fork_ami_US2105_169
Comment 3 jizhao 2012-09-27 07:09:24 EDT
Verify this bug on fork_ami_US2105_169.

Actual results:
rockmongo can be embedded and used successfully.

Note You need to log in before you can comment on or make changes to this bug.